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INTRODUCTION




Microsoft excel is an excel-based office software program that can make complicated data available for easier interpretation. They have designed this version with the help of professional analysts and users to make the data available to them. Microsoft excel supports a wide range of programs and features that are not available in the standard excel version. You can access the excel data and analysis directly through a software which is called Microsoft Excel for Power Query. One of the best features of this software is that it gives the detailed analysis of the data and gives it a proper format. You can convert the entire database into the format of CSV file as a single file and it is very easy to access the data.


[image: ]



What is Microsoft Excel 2021?



Some analysts make the standard excel for use with office applications and spreadsheets. This version has some limitations, like it cannot save in PDF format or can perform some complex data tasks. You can use this software with other MS office applications to create simple spreadsheets. You can add your own pictures, shapes, tables, etc. and use the data to solve many complex problems and make some very useful data available. You can convert the entire excel file into the CSV file.



Microsoft excel 2021 contains several features that make it great for the beginners. In this guide, we will go through all the features in detail and find out what is new in Microsoft excel version 2021.



Here are the new things in Microsoft excel version 2021:




 
 New UI




 
 Color schemes and themes for easy on-screen readability




 
 Microsoft excel for beginners




 
 Table of contents




 
 New interface



Microsoft excel has changed the look and feel of excel over the years. Microsoft excel 2021 has several UI improvements, for instance the new ribbon added in office 2007 and 2010. In the recent version, we can see several small enhancements. One of them is the interface. They have redesigned Microsoft excel to look at ease. The tabs have moved, there are several color schemes and themes inbuilt, and of course, the recent version comes with several bug fixes.



To understand how to use Microsoft excel better, let’s take a look at its interface;



A new UI in Microsoft excel version 2021 is new tab grouping. They can split the excel sheet into multiple tabs. In the new UI, the user will notice a vertical strip of a tab in the top and bottom. This strip will group the tabs by their name. You can also use the “Group by Name” option to select the group to use. Selecting the group option will show the same group of tabs in a new vertical strip at the top. Clicking on a tab will change its color.



The new UI will now let you work more efficiently. There are many small enhancements, but the most significant one is the UI redesign. Now you can simply drag-and-drop sheets to group the tabs. Also, there are new color scheme and themes. There is one more small enhancement which will be helpful in creating charts. The new UI introduces multiple color scheme and themes inbuilt.














CHAPTER ONE





The Excel 2021 Program Screen Keyboard Shortcuts
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Getting Started




When you open an Excel, the Excel Start Screen will show up. From here, you’ll have the option to make another exercise manual, pick a layout, and access your recent worksheet (s).




To make a workbook





 
 Click File




 
 Select New or press
 Ctrl +




 
 Double tap an exercise manual




To open a workbook





 
 Click File




 
 Click Open or press
 Ctrl + O




 
 Pick a new document or explore the area where the document is saved




To See and Print a Workbook





 
 Click File




 
 Select the document and Print



To Undo:




 
 Click Undo on the Quick Access Toolbar.



To Re-try or Repeat:




 
 Click
 Redo
 on the Quick Access Toolbar.




 
 It repeats once everything has been re-done.



To use Zoom:




 
 Click and drag the zoom slider to one side or right.



To choose a Cell:




 
 Click a cell or utilize the console bolt keys to choose it.



To select a Cell Range:




 
 Click and drag to choose a scope of cells. Or press-hold down the Shift key while utilizing the arrow keys to move your choice to the last cell of the range.



To select an Entire Worksheet:




 
 Click
 ‘Select All’
 where the section and line headings meet.



To choose the Non-Adjacent Cells:




 
 Click the first cell or range of cells.




 
 Hold down
 Ctrl
 and select any non-opposite cell or cell range.



Cell Address: the directions refer Cells to produced using their segment letter and line number, such as cell A1, B2, and so forth



To leap to a Cell:




 
 Click in the
 ‘Name Box’




 
 Type the cell destination you need to go to




 
 Tap
 Enter
 .



To Change Displays:




 
 Click the display icon in the status bar. Or.




 
 Click the View tab




 
 Select a display




To recuperate an Unsaved Workbook





 
 Restart Excel




 
 If it can recuperate an exercise manual, it will show up in the
 Record Recovery sheet
 . Or.




 
 Select
 File




 
 Click
 Recover unsaved exercise manuals
 to open the sheet and choose an exercise manual from the sheet














CHAPTER TWO





Keyboard Shortcuts





General




To open an exercise manual:
 Select
 Ctrl + O



To make another exercise manual:
 Select
 Ctrl + N



To save an exercise manual:
 Select
 Ctrl + S



To print an exercise manual:
 Select
 Ctrl + P



To close an exercise manual:
 Select
 Ctrl + W



For help:
 Tap
 F1



To enable ‘
 Tell Me field’
 :
 Select
 Alt + Q



To spell check:
 Select
 F7



To find out worksheets:
 Select
 F9



To make outright reference:
 Select
 F4








Route




To move between cells:
 Select
 ↑↓←→



To
 write
 a cell:
 Select
 Tab



To
 left
 cell:
 Select
 Shift + Tab



To
 down
 a cell:
 Select
 Enter



To
 up
 a cell:
 Select
 Shift + Enter



To down a screen:
 >>>
 Page Down



To first cell of dynamic column:
 Select
 Home



To
 End
 mode:
 Select
 End



Cell
 A1:
 Select
 Ctrl + Home



Last
 cell:
 Select
 Ctrl + End








Altering




To cut:
 Select
 Ctrl + X



To duplicate:
 Select
 Ctrl + C



To paste:
 Select
 Ctrl + V



To fix:
 Select
 Ctrl + Z



To redo:
 Select
 Ctrl + Y



To find:
 Select
 Ctrl + F



To replace:
 Select
 Ctrl + H



To alter dynamic cell:
 Select
 F2



To clear cell substance:
 Select
 Erase




Designing




Intense:
 Select
 Ctrl + B



Italics:
 Select
 Ctrl + I



To underline:
 Select
 Ctrl + U



To open Format Cells:
 Select
 Ctrl + Shift



Discourse box:
 Select
 + F



To select All:
 Select
 Ctrl + A



To select a column:
 Select
 Shift + Space



To select a segment:
 Select
 Ctrl + Space



To hide rows:
 Select
 Ctrl + 9



To hide columns:
 Select
 Ctrl + 0






















CHAPTER THREE





Edit a Workbook





Alter a Workbook




To Alter a Cell’s Contents:




 
 Select a cell and snap in the Formula Bar or double tap the cell.




 
 Alter the cell’s substance and press Enter.








Clear a Cell’s Contents




To clear a cell content;




 
 Select the cell(s) and press the Delete key.




 
 Or, click the Clear button on the Home tab and select Clear.








Cut or Copy Data




Select cell (s) and snap the Cut or Copy button on the Home tab.








Preview an Item Before Pasting




Microsoft Excel 2021 has outstanding feature to easily paste any of the item from clipboard without the need to copy and paste.



To quickly preview an item before pasting:



Step 1. Select the text/cells which need to be displayed in the spreadsheet.



Step 2. Right click on the cell/s that contain the items and click on ‘Paste Special’. A dialog box will pop up, asking whether the selected items need to be displayed in the spreadsheet.



Step 3. Click on Yes.



You will notice that the values will automatically appear in the spreadsheet. If you need the other spreadsheet to be displayed, just click on ‘Paste and Match Style’. This will then display the entire column in the desired spreadsheet.








Paste Special




This feature is a great tool to move selected cell into another cell in different location. To use this feature, you need to do the following steps.




 
 First, select the cell where you want to paste the data.




 
 Second, right-click on that cell and select “Paste Special”. The next window will appear on your screen. This is a list of options for Paste. Now choose the option Paste Special.








Move or Copy Cells Using Drag and Drop




What are the basic functions to move and copy cells using drag and drop?



The following examples will help you answer the question.



Let’s say that you want to move the 1st and 2nd cell to some other location or you want to copy the cells instead of moving it.




 
 Click on the row to select the cells




 
 Click on the Home button and right click on the selected cells to access the copy or move option



If you want to move the cell, you can select the cells by holding the Ctrl key down and click and drag the cells to the new location you want them to go to.








Find and Replace Text




To start, open the Find and Replace dialog box by pressing the F1 key on the keyboard. Once the dialog box is open, the easiest and fastest way to replace text is to use the Replace with button.



Click the Replace With button and it will take you to the next tab of the dialog box.








Check Spelling




On the top left you will see the drop-down menu, click on Info and then click on the option of View. In that way, you’ll be able to see it in a way that you need. As you can see, it can check the spelling from the list of options. If you want to check spelling from the cell rather than the complete document, you have to go to the cell options. But if you don’t check spelling with spell check, then you cannot save it. Then you’ll be redirected to a cell.



Now that you have entered the place you want to check spelling, click on the Edit option and then click on the option of Find & Replace. In the box, you can write the word and you’ll be redirected to the Microsoft Office find & replace options.



But you will need to select the option called find in the current window. Click on the find button and write the word that you want to check spelling. Press Enter or Ok. Now click on the Replace and that’s it!








Insert a Column or Row




When you create a new worksheet, Microsoft Excel adds rows and columns in the top left corner of the sheet. These two rows and columns represent the empty rows and columns in the worksheet. You can customize these empty rows and columns by adding rows and columns to your worksheet. In other words, when you first open a new worksheet, you can add rows and columns to it to represent the data in your worksheet.



Note: You cannot insert rows and columns when your worksheet is protected. To insert rows and columns into a worksheet that is protected, you must deactivate the worksheet’s protection.








Delete a Column or Row




With the use of the “Cells” command, you can delete a cell by selecting it then using “Delete” or “Delete row” or “Delete column”. You can also press CTRL+C, and then CTRL+V.








Hide Rows or Columns




To quickly hide rows or columns, you should be able to click on the column header, go to the “Column” menu, and choose “Hide/Unhide”.



Alternatively, you can go to “Data”, and select “Hide/Unhide” from the menu at the top right


























CHAPTER FOUR





Basic Formatting




Excel 2021 is easy to use and simple to use. But there is more to Excel than just using the “formula bar”. Excel provides some basic text formatting tools such as bolding, underlining, italics, text coloring, etc. which is far better than many of the applications out there. For example, there are lots of sites that offer text formatting solutions. However, most of them force you to design the complete text. It could be difficult and not always possible to know how your intended text will be used. It could be hard to adjust formatting when text needs to be updated or changed.








Change Cell Alignment




Alignment and cell format are two of the most important things in working with data. They help you organize and create different views of your data in a better way. Microsoft excel is one of the best tools to handle data and has a built-in facility to control and work on it. Most of us have used Excel for handling any kind of data. And in most of the occasions. The issue with aligning cell is that it’s very difficult to manage as it might make your data unreadable. There is another alignment option available that works better than the default and that is the left, center, and right alignments. This is the best way to align data with. It’s easier to manage and less likely to damage the data in any way.




How to Change Cell Alignment




To change any of the tables, you need to use the Format option. You need to open the Format option from the list on the left pane and then you can work on it regarding the right-hand pane. The left-hand pane displays all the formatting options and it’s the easy way to set the formatting options for any of the cells.



For example, you can see all the available options in the left-hand pane, right? To set the cell alignment, you need to click on the cell that you want to align and then you can select any one from the three options.








Format Text




The text formatting menu has so many useful tools for formatting, you can simply enter the text that you need, add some basic text formatting, and get the text formatted with ease.



Let’s get started.



How to Bold Text




 
 You can bold a piece of text by going to the text, go to the formatting menu, and select “bold”.




 
 Bold the text by simply clicking on the desired text.



How to Change Text Color




 
 Go to the formatting menu and select “text color”.




 
 Change the color by simply clicking on the desired text.



The last text formatting method you’ll see here is “font”. To change the font, go to the menu at the top of the page and select “format cells”. This is where you can do many of the things you can do when you format the cells.



Change font to a more readable font.




 
 Change font by going to the cell where you want to change the font and the formatting menu. Select “font”.



How to Bold and Italicize Text




 
 In order to create bold and italicized text, there are three ways to do it: you can use the “bold” function, the “italic” function, and the “font” function.








Format Values




There are a lot of times when you are working in Excel and you have to format the values in a specific way. You may have to create a column with prices in percentage format, or add a prefix or a suffix to the number before displaying them in the spreadsheet.



Some examples include



1. Displaying the Total Sales Amount in Currency format.



2. Displaying the Total Sales Amount in Percentage format



3. Adding % to the end of the Number



4. Displaying the Date in the Month Month Day Year format.




 
 The first example is relatively easy to achieve.



To format the total amount in currency format you will need to add a formula to it. (it adds CURRENCY format to the cell).




 
 This is one of the most used excel formula



To format the percentage in percentage format, you will need to add a percentage formatting to the cell. (it adds PERCENTAGE format to the cell).




 
 The third example is quite simple. We have provided a formula to add % after the number. This is useful if you need to add % symbol to the end of the cell value




 
 The final example is quite straightforward. We will be adding the MONTH, DAY and YEAR to the cell, which makes the cell value look like “Month_Day_Year”. The format for the date is MM/DD/YYYY, so the easiest way to achieve this is to add % in front of the cell and then the above format to the cell.








Wrap Text in a Cell




To wrap text in a cell, we will be going over three methods which will help you to wrap text to the cell, the methods are by the following names:



1. Wrap text to the cell with Microsoft Excel.



2. Apply wrap text to a whole row or cell.



3. Apply wrap text to a row or cell by using a formula



Let’s have a look at all three methods:



How to Wrap Text in a Cell with Microsoft Excel:



As I mentioned before that there are three methods by which we can wrap text to the cell, these methods are:



Method 1: Wrap Text to the cell with Microsoft Excel.



We can use this method only if your Excel file is opened in the compatibility mode. In this method we need to do some steps as follows:




 
 On the ribbon, choose Insert>Text>Wrap text to the cell (or press Shift+F9).




 
 Select the cell or rows that we want to wrap the text to. You can drag the corner of the cell to select or we can also go to Home tab>Cell>Wrap.




 
 Select the type of wrapping that you want, there are three choices:



Center: Centrally place the text within the cell.



Left: Place the text to the left of the cell.



Right: Place the text to the right of the cell.



Method 2: Apply wrap text to a whole row or cell.



In this method, we use the same methods which we used in method 1, but the text will be wrapped to all the rows or cells. In this method we need to do some steps as follows:




 
 Open the Excel file and go to Home tab>Cell>Wrap.




 
 Choose the type of wrapping as left, right or center.




 
 Click OK.



Now the text will be wrapped to the rows or cells.



Method 3: Using a Formula.



If you want to wrap text in a row or cell without opening the Excel file, you can also use a formula. Here is a brief about the formula:




 
 [TRIM(CHAR(34)&CHAR(34)] &A1 & [CHAR(34)&TRIM(CHAR(34)] (where A1 = cell in which we want to wrap the text.)



The formula in step 3 will be changed when you write the formula in A1.







	
Merge Cells





The Merge function is used to merge ranges of cells, based on the content or values contained in the cells. This option performs a merge only if no value is specified in the cells.



How to merge multiple cells.



You can merge multiple cells in two ways:




 
 By simply clicking the Merge button in the Home Tab of the ribbon. This will bring the Merge function’s drop-down list and you can select the Merge option. If you need to choose different cells, you will need to click on the “Advanced” button and choose the cells you need to combine.




 
 By using the Selection or Cursor functions. Once you select the cells that you want to combine, you will need to do one of the following:



Include all values: The values from all selected cells are merged and returned as a single cell.



Exclude all values: All selected cells are ignored and the values from the original selected cells are returned in a new worksheet.



Merge range of cells: The values from the selected cells are combined based on their content, using either the first, last or any cell in between. The options are based on the following.



Merge last cell – The merged values are combined based on the values of the last cell in the range of cells. This option creates a single cell with the merged values.



Merge first cell – The merged values are combined based on the values of the first cell in the range of cells. This option creates a single cell with the merged values.



Merge any cell in between – The merged values are combined based on the values of any cell in between the selected cells.








Cell Borders and Shading




This is a great trick if you have some sort of background color, text etc in excel, but want to be able to edit the shading, as well as color of the cells and even their borders.



To begin:




 
 Go into menu and choose View > Conditional formatting > Highlight Cell Rules > Check Show borders




 
 If there is already a choice available then you can just press the space bar.




 
 If there is no choice available then there is no easy way around this, you will need to manually add the option, but it is not difficult:



Open up the dialog box




 
 Go to Conditional formatting > Highlight Cell Rules > Manually Set rules and select a color for the cell borders or check the box under show borders and hit ok




 
 Click ok




 
 Repeat for any other colors you want in the spreadsheet








Copy Formatting with the Format Painter




The most simple and intuitive way to copy formatting is to use the “Format Painter”. You may have seen the format painter in the context of the Home tab’s “Paste Options” and “Format Painter” sub tab.



Before going any further, let’s see how to use the Format Painter.




 
 You can use the Format Painter by clicking on the cell. The Format Painter shows up as a blue bar, as shown in the below screenshot.




 
 By clicking on the red box, you can select a range of cells. The Format Painter is also available on the Home tab of the excel.




 
 The Format Painter shows the formats that can be copied to the selected range. You can drag the Format Painter to see the entire format applied to the selected range.




 
 To select a format using the Format Painter, click on the selected range and then, from the dropdown, select the format you want to copy.




 
 When you select the format, you can see the Format Painter shows the applicable style. To copy the applied style, click the arrow next to the dropdown box. It automatically applies the format of the first format item.




 
 If there is a more complex format, you can use the “Format Painter” feature to copy it to the selected range.




How to copy formats using the Format Painter





 
 For the first style format, you can simply click on the dropdown box, select “Copy Style” and apply the format.




 
 After that, for the second style, you can again click on the dropdown box and select “Copy Style”.



You can do the same for any number of formats. However, if the formatting contains a complex formula, you can click on the dropdown box again and select “Apply to Selection”. You can copy this formatting to multiple cells at once.








Adjust Column Width or Row Height




As we know in MS-excel, you can adjust the column width and row height of a cell. Before adjusting any cell height or width, we must first make sure that the column width and row height is locked in the first place. The cell should be locked if you make any modification of any cell, it will be reflected in the others.




 
 To lock the cell height and width, Right click the cell and select “Format Cell”. Click the tab “Conditional Formating”. Check the checkbox that says “Lock this cell”.



To change the column width:




 
 Select the cell which should adjust its column width. Press and hold ctrl key on your keyboard and select Column Width from the list. It will open the dialogue box.




 
 Change the column width value and click OK. The column width of this cell will change accordingly.



If the column width value is too wide, you may have to click the down arrow in column width value bar and select “1.25” to reduce the column width of this cell.




 
 To increase column width, do the above steps again. If you are changing the column width with a percentage, like 100%, you may need to multiply the value of percentage with the column width value. It means, if the column width value is 50, you may need to divide the value by 2 or multiply it by 2 to get the new column width value.



For example, you need to adjust the column width to 150%. You may need to change the value from 100% to 150% (or 150% x 100%) to get the column width value of 150% (or 150% x 100%).




 
 If you select a number other than 1.25, it will be rounded off.




 
 If you select decimal numbers with a comma separator, you will need to use a format that can display this format in your browser. For example, if you select a comma separator for the values in your column, you may need to select a comma separator on your browser too. You can also select any other character separator, such as semicolon.






































CHAPTER FIVE





Basic Formulas




Formulas are a useful tool for business use. The most useful formulae are the basic ones, and are used to calculate basic information. In this chapter, we will be covering basic formulae in Excel 2021, to make your work as Accounting or bookkeeping much easier.








Enter a Formula




Excel is designed to be simple and this is evident from it’s design. A formula cannot be entered in Excel by typing. You can select a cell or a group of cells to which you want to apply a formula, this is known as entering a formula. Entering a formula is quite similar to entering a text in any editor in Linux/Mac. You will see a cursor in the editor in the same way as you see a cursor in the excel spreadsheet. The cursor means that the editor is focused on that particular text. In this case, the cursor is the place where you would type a formula, so in order to type the formula you need to do three things:



1. select the cells



2. click on the place where you want to type the formula.



3. Enter the formula








Insert a Function




There are two ways to add your own function into Microsoft Excel:



The first way is to insert a function by copying an existing function from Excel and changing it as per the requirement. This method is the easiest and the fastest.



The second way is to create your own function by writing a code. This method takes a lot of time, but it is complicated to create your own functions.




Inserting a Function by Copying an Existing Function




One of the simplest ways to insert a new function in Microsoft Excel is to copy an existing function and change it as per the requirement. You can access all the standard Excel functions in the “Excel function library.”



To add a new function, you need to access the Excel function library. When you open Excel from the start menu or using the shortcut keys Ctrl + Q, you need to navigate to the “Insert” option from the “Office.”



There are many function categories to choose from. You will find many functions for performing calculations, creating statistical tables, and many other things.








Reference a Cell in a Formula




I only seen a reference cell in the formula, the value of the cell in the spreadsheet doesn’t matter. The cell you want to reference in the formula doesn’t have to be in the same workbook and on the same worksheet as the cell used to make the formula.




 
 To reference a cell in a formula, hold down CTRL and select the cell you want to reference, like so.




 
 To reference a cell you have opened a “Formula bar” window (ALT+F11), and have selected the cell you want to reference, like so.




 
 The value of the cell that you selected to reference, doesn’t need to be in the same workbook as the one where the formula is.








SUM Function








Before you can enter a function, you need to define it. Start by selecting the cell you want the function to be in.




 
 Press Ctrl+1




 
 On the Summary tab, click the down-pointing arrow to open the Function dialog box.




 
 In the Function name text box, type the function name you want to use.




 
 In the Function Arguments text box, select the data range or cells to which you want to apply the function.




 
 In the Function Result text box, type the result you want the function to return. The function will then display in the Function Arguments box.




 
 You can also define the function as an array formula.



When you press Ctrl+1 to select the function, you can choose to enter the function as a sum, array, or text function.



Excel function SUM function sums all the numbers of a selected range in a selected worksheet. This is a very useful function. If we select a range and press the F9 function, Excel will calculate sum of all the numbers in that range. The formula will look like this,



Sum(A1:A10)



When we use the function F10, Excel will display the result in a particular cell.



Sum of all the numbers in a range



Now we can take it one step ahead. Let’s take an example and we have selected a range (A1:A20) and we want to know what will be the total value of this range?



=SUM(A1:A20)



Note: We did not define the size of the range. If we want to limit the size of range, we need to define it by using the * (asterisk) and this will limit the range from A1 to A20.



Now we can select all the numbers in a particular range and we can see the result.



=SUM(A1:A20)








MIN and MAX Functions




MIN and MAX functions are used for finding the minimum and maximum values for multiple rows in a column. The MIN function finds the lowest value in the data set, and the MAX function finds the highest value in the data set. They are not visible in formulas of a table, however, they can be visible in formulas of a cell, and it has special appearance called Formula Bar. The formulas below shows MIN and MAX functions.




 
 Enter the data in any column A of a worksheet, then put the formula in B2 like =MIN($A2:$A10) and hit [enter] key. You can see this, MIN function’s output will appear in the formula bar of B2.



If you want to repeat the formula, you can hit CTRL+SHIFT+[enter] key combination to execute the formula several times.








COUNT Function




COUNT function returns number of records which have been entered in the selected cells. You can type it in the cell itself or type it as a formula. If the first row of a selected range of cells is a header row, it is counted as the first record.



Syntax: =COUNT(rng1;rng2;rng3;rng4;…) rng1, rng2, rng3 and rng4 are the ranges of data in which you want to count records.



Use these steps to understand how to use this function:



1. Select any cells in the range.



2. Choose from the Home tab of the ribbon. Then click on Insert>Function.



3. Click the arrow button to select COUNT.



4. Type the number of rows you want to count and press Enter key. The result will be listed at the bottom of the cell.


















CHAPTER SIX





Insert Objects




This topic is about INSERTING DATA INTO Microsoft Excel. In this subject the term “insert” is short for “Insert Object”. Inserting Data into Microsoft Excel is a very simple task. I’ll be describing each step in detail. The steps for inserting Data into Microsoft Excel are:



1. Opening a new workbook (or “workbook”)



2. Opening a new worksheet (or “sheet”)



3. Clicking on the NEW button on the ribbon to open the OBJECT library and select the object we want to insert



4. Clicking on the OBJECT button on the ribbon to insert the selected object



In this chapter, I’ll describe how to insert the picture or chart object (picture or chart) to the selected worksheet, but you can insert the other objects as well such as: shapes, text or images, etc.








Complete a Series Using AutoFill




Notice that each time that I enter a new person into one of the cells above, the next time that I hit Enter, the same color name goes to the next cell. This happens because there is no cell next to the first person. Instead of using the regular “fill” feature, we will use “AutoFill”.



First, go to the “Format Cells” section and make sure that the box is checked, for the option “Fill down”. This will cause every cell that is full of text to turn into a series that will fill automatically. Then we need to make sure that “Fill series by list” is checked. If you try to do this without this setting, it will try to fill the cell to the first and then it will move on and fill cells next to it. This will prevent it from working.



Next, click on “Format Cells” and make sure that “Cell Type” is set to “Number” and “Base” is set to “0.0”. If your base number is not “0.0” then you will need to turn this off.



Next, click on the “Insert Function” dropdown and select “AutoFill”. After that, set “Fill list” to “Last Name”. Then click OK








Insert a Shape




Inserting a shape can be a confusing process to many users. The basic objective of inserting a shape is to insert a picture of what you are talking about, so that your data can be easier to read or to identify. This is particularly important when you are talking about data that is stored on a sheet. We have a few tips to help you out.




What is the best shape to insert in Excel?




The shape of a data bar is the most common. We typically use two different symbols to indicate the data. The shape used is almost always the same, so people don’t need to think about it. It doesn’t matter what color or shade of the image you choose. However, you can use whatever shape you like or like colors. Just remember that what you choose will influence how your data will appear and it is best to choose a symbol that works well with the data you have.




How to insert a shape





 
 Open Excel and choose the Data tab at the top




 
 Go to Insert > Picture. Here, you can search for your image or you can insert one you have already placed on your hard drive




 
 Now that you have the picture selected, you can click and drag it to where you want it



To insert the picture, move the picture to where you want and then click inside of Excel to select it. Once you have selected the picture, just click ‘Insert’








Hyperlink: Text or Images




Hyperlinks work in plain text, text or image format. A cell can have one hyperlink or multiple. When the cell is edited, the links will update with the new data when the program runs to preview or recalculate the data.



The following paragraphs provide more information about creating hyperlinks, and about linking multiple cells with one hyperlink.



Creating a hyperlink



To create a hyperlink, select the cells that you want to link to, then select “hyperlink” in the “insert” menu, as shown in Figure



1. The program will open a shortcut menu where you can select the destination, the link text, and more.



You can use your mouse to select the cells. To open the shortcut menu, select the cell and press Shift+Ctrl+Alt+V.



Alternatively, you can select one or more cells, right-click the mouse, and select “hyperlink”, or press Alt+K.



Link text:



To add a hyperlink to a cell, use the Link text box, shown in Figure



2. Click in the box, then press Shift+Enter to add a new link. You can use text (case does not matter), but you must use alphabetic characters only.








Modify Object Properties and Alternative Text




Object properties provide us an option to modify text, color, font size, font style, align, vertical and horizontal position of the object. Just select the object and then right click on it. It will give you the options to define the object properties. This is a handy tool and it has many benefits. First of all, you don’t need to open the dialog box to make changes. These changes will reflect immediately. And also, we will be able to modify the properties of multiple objects at a time.



When we work with images, we need to set the text we want to replace the images. There are two ways to do this. One way is to click on the text and click on the Insert Alternative Text icon. It will give the option to set the text for that particular object. The other option is to select the image, right click on it and click on the Insert Alternative Text icon. In this way we will be able to add the text on top of the image as we did in our previous article.














CHAPTER SEVEN





View and Manage Worksheets




Microsoft Excel is the most useful data cruncher there is. But, when there is a need to make some graphs and view the results, sometimes that’s not quite possible. Most of the times this is due to the limitations of the built-in options of Excel. In this chapter, we will talk about how to solve the most common problems of viewing and managing worksheets.



If you are familiar with the standard version of Excel, then you might find this chapter really easy to understand. So, here we go…








Insert a New Worksheet




Excel provides us many possibilities to format, organize and arrange the data. But we face a problem when we try to insert a new sheet in an existing excel workbook. In this article, we are going to discuss various ways of inserting a new worksheet in Microsoft Excel Workbook.



By inserting a new sheet in Microsoft Excel, we can create a new workbook or modify the existing workbook. Using Excel, we can create several new sheets and then we can edit the existing sheets. By using the tools provided in Microsoft Excel, we can easily do this task.




 
 Open the existing excel workbook and then press Ctrl + Shift + N keys.




 
 The window with different ways to insert a new worksheet will open.




 
 Choose the method you want to insert a new worksheet.








Hide a Worksheet




Before we begin, you’ll need to make sure that you have permission to hide sheets in Excel. Some people don’t have this ability, which makes sense because otherwise, you wouldn’t need to hide anything.



To get started:




 
 Click the File menu




 
 Click Options




 
 Click Trust Center




 
 Click Trust Center Settings.




 
 Scroll down to Personal.




 
 Click the Show option and scroll down to the Hidden Sheets section.




 
 Click Trust Center Settings and click OK.



If you don’t have this permission, it will ask you if you want to add more sheets to the trusted zone and you’ll need to click Add another sheet. You will add the file in this folder and then you’ll need to click OK.



To begin, click the File menu, click Open. You will open up a window where you can open a file. On the left-hand side of this window, there is a place for you to input a file name. You will input the name of your file and then you will click Open.



Next, in the Excel window that opens, we will right-click the sheet that we want to hide and then click Hide.








Rename a Worksheet




You can rename a worksheet from its Properties page. By right-clicking on the worksheet, then choose Rename from the menu. A new dialog box will pop up, in which you can type in a new name for your sheet.



To change the name for a single sheet:




 
 Select the sheet you want to rename.




 
 On the sheet tab, choose the Rename icon.




 
 Click on the Edit button next to the new sheet name, to rename it.



Renaming Sheet Names is a very powerful feature in Excel. This worksheet tool allows you to change the name of all your worksheets at once. This will allow you to rename all your sheets at a go, reducing the workload by several seconds.








Change a Worksheet’s Tab Color




To begin:



1. Click on the Home tab



2. Select the format of the Tab color from the “Customize the color” group (as highlighted below)



Note: You can make any change as per your convenience. You will see the color change immediately. All you need is a copy of the template file.








Move or Copy a Worksheet




To move or copy a worksheet;




 
 Go to Home tab in excel.




 
 Go to the Ribbon and find the “Move” icon.




 
 Then click on the icon and a window appears.




 
 Here, select the source location and then drag the sheet you want to move.




 
 If you are moving from a different location, you will see a blue arrow. There you can see an option to select the location where you want to move the sheet.




 
 If the worksheet is large, you can drag it so that the sheet is in a view you are comfortable with.




 
 Once the sheet is in the desired location, you can double click on the sheet.




 
 When the sheet is opened in the desired location, it shows the blue arrow symbol. This is to indicate that you have moved it from the source location to the destination location.




 
 If you have moved the sheet from one location to another you can click on the arrow and if you want to move it to another location in that same excel sheet. Or, you can click on “Paste” icon on the home tab in excel.




 
 This shows you a pop-up window where you can select the location.








Switch Between Excel Windows




There are many excel shortcuts you can use to switch between windows. By default, there are three windows. The first one is called excel, the second one is called excel.xls, and the third one is called excel.xlsx. You can use the keyboard shortcuts as well as the windows switch. The shortcut for switching between excel and excel.xls is ctrl + alt + enter. The shortcut for switching between excel and excel.xlsx is ctrl + shift + enter. Also, the shortcut for switching between excel and excel is alt + enter.



Windows Switch




 
 Open excel and press alt + enter. The keyboard shortcut to switch between excel and excel.xlsx.




 
 Open excel and press ctrl + shift + enter. The keyboard shortcut to switch between excel and excel.xls.




 
 Open excel and press alt + enter. The keyboard shortcut to switch between excel and excel.xls.








Freeze Panes




Freeze panes are also known as tab stop panes. You can use them to put extra tabs. A freeze pane is simply another tab which is created by Excel itself. It looks like a tab but has some distinguishing features. The way you use them is very interesting. We will explain the details of how to create them and also explain how to use them.












Creating Freezes Panes




The best way to do this is from a data view. You will need to create a data view first.




Add Freeze Pane in Data View





 
 Open an Excel data view and create the first blank row.



Add a freeze pane using the following steps:




 
 From the data view, select cells or rows that you want to freeze.




 
 Go to the View tab, then from the Data group, click Freeze panes.




 
 Select Freeze pane in the dialog box that will open up.








Select a Print Area




To print all or parts of an entire worksheet in Microsoft Excel, you can select a range of cells that you wish to be printed. You can select a single cell, a group of contiguous cells, or the entire worksheet. If you want to print the entire worksheet, be sure to check the check box for Print Entire Selection.



Note:



If the Print Range dialog box is displayed, you must click OK to dismiss it and then click OK to print. If you leave the Print Range dialog box on the Excel screen, your changes will be lost. To get ahold of the dialog box again, you must click the Home tab and then click the Print button.














CHAPTER EIGHT





Chart Elements




In this chapter, we will go through how to build a chart. This is another type of chart with no data but only the line chart and the line chart have lines that start at (0, 0) but moves towards the right as it draws.
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Create a Chart




There are different types of charts and graphs that we can draw on the basis of the requirement and need. We can draw the graphs on the basis of the different types of charts like bar, line, pie, scatter, column, area, and many more. So, here we will explain all the methods to create the graph using Excel. Let’s start the tutorial by creating the basic chart using Excel.



Step 1 – Open a new Excel sheet, and add the column for the data. So, in the first step, we have to add the columns for data on the basis of which we can draw the graphs. So, we need to add the columns for data in excel sheet.




 
 Click on the Excel icon and click on Add




 
 Click on the Excel file and search the required sheet.




 
 Drag and drop the desired cells in the specified location.




 
 Click on the Insert button to continue.




 
 Next, we have to add the columns for the data. So, click on the Data option, and click on the List option.




 
 Now, we need to select the type of list, such as category, date, time, or a combination of these items. So, the default type of list will be selected as the category. So, this is the list we have selected.




 
 Then, simply select the data and then click OK.



If we want the value, select the data and then click on the data values list to see the values of data.



If you want to use this data with the bar graph, select the cell where the value is.







Step 2 – Add the chart type. In the next step, we have to add the chart type.




 
 So, click on the Design option, and search the option.




 
 Click on the Column option to add the bar graph.




 
 Select the size and the fill pattern of the graph.




 
 We can also customize the graph as per our needs.




 
 Click on the OK button to continue.








Move or Resize a Chart




Moving a chart in excel is pretty easy. To start, you can select the entire chart (hold the Shift key while moving your mouse) or you can choose to click on an individual element or cell of the chart, after which you should move that element by dragging or scrolling.



You can resize a chart as well. For this process you need to select the chart and then choose an appropriate size on the bottom right part of the chart.



Moving a chart is a very intuitive process, but resizing a chart is a bit more complex because you have to understand two sets of numbers, and you also have to be careful that you don’t alter your actual data by altering your chart itself.








Change the Chart Type




In Microsoft Excel, charts are a useful tool for quickly conveying information to the audience. As far as chart types are concerned, we have three different type of charts which are Bar, Column, Line and Pie charts. You can easily change the chart type, but in the default chart, the chart type is set as Line chart. But you can easily change the type of a chart.




How to change the chart type in Excel




1.Select the chart that you wish to change the chart type, you can check below for the different chart types available in Excel.



2.Select the Chart Type, then click the box in the chart and choose the one you want.



3.Save the new chart and give it a name.



4.Close your workbook.
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Filter a Chart




Answer:



In Excel, each data set in a chart is called a data series. Each data series is a line on the chart. If you can choose from more than one data series, you can filter the chart so that only certain data series show.



In this article, we show you the steps required to create a chart that shows only the first few data series. We also show you how to change the color scheme, font size, and background of the chart itself. Finally, we show you how to create a more complex chart in which you can filter out unwanted data series.



To create a chart that only shows a certain data series, first select the chart that you want to modify. On the chart object, select Format from the Charts category. You will see a dialog box that looks like Figure A.








Position a Chart’s Legend




I know you can add legend using a chart, but you’ve got to go to the chart and position it there in its own way. Here is how to do it in Excel and I’ll go through some examples of how you can actually position your chart’s legend.



So, if you need to position your chart’s legend on top of the chart, let’s look at that first. So, if you click on the chart and then go to its properties. It’ll have a section on the right-hand side of the screen which says chart legends.












 
 Click on chart legends.



There’s three different options you can position your chart’s legend on top of the chart. Let’s look at those now. The first one is the top.




 
 Click on the top option. This will just position your chart’s legend at the top of the chart. You’ll notice right away it’s going to move your chart and the legend.




 
 The second one you can do is the bottom of the chart.




 
 Click on the bottom option. This will just position your chart’s legend at the bottom of the chart. You’ll notice right away it’s going to move your chart and the legend.




 
 The third one is the corner. Click on the corner option. This will actually position your chart’s legend so it is the top-left corner of the chart.



If you want to position it off to the side you can position it right next to the graph.








Show or Hide Chart Elements




If you don’t want to show the chart, set its Visibility property to False.



However, a chart shows only the elements you select when you make it visible. If you want to display a chart only for cells in certain ranges, you can select and hide the chart for those cells in the same way you select and hide a row or a column in a table.



(This is also relevant for hiding rows, if your table has multiple rows, like a table for a calendar. You can hide or unhide the entire row if you use the same technique.)




 
 Go to Formulas tab > check “Show/hide” and check “Show chart”. This will show the chart when you are using a specific range for date.



If you don’t need to hide the entire thing, go to the tab “FORMULAS”, then select “Show/hide”. You can then select the columns that you want to include in your chart.








Insert a Trendline




A trendline is used to help determine a pattern in the data. It is used when a set of data shows a specific pattern for the past few months/years. A trendline can be used in all kinds of data ranging from profits to sales. To insert a trendline, follow these steps.



Select the data and place a clear trendline at your desired angle. Insert your trendline by following the steps below.



1) Select the data.



2) Use the Format Selection Button to select the data only.



3) Move the cursor to the data you wish to insert the trendline on.



4) The cursor will change from a pencil to a circle. Move your cursor to the column you want the trendline to be inserted on.



5) Click on the top of the cell you have the cursor on. This will insert the trendline at the bottom.








Insert a Sparkline




It is very easy to insert a sparkline in Excel. Let’s begin with a very basic overview. First, you have to select one of Excel’s built-in chart types, and then choose to convert the chart into a sparkline. You can convert any chart type to a sparkline.



To insert a sparkline, you can either select the chart that you want to convert to a sparkline, then click on the Insert Sparkline button at the bottom of the Formatting Ribbon. Or, you can select the entire range that you want to use, then click on the Sparklines button, and then the Insert Sparkline button.



Here’s the first step. Select the first chart, which is a line chart, and click on the Sparklines button on the bottom of the Microsoft Excel Formatting Ribbon. You’ll see the Chart Type Sparklines dialog box. Choose the Line chart type, and then click on OK.



This will display a list of various sparkline types. You have a few choices, such as Bubble chart, Candlestick chart, Line chart, and Column chart. I’ll explain how to use all of the options later. First, select Line chart, and then click on the down arrow at the right side of the Sparklines dialog box.



This will display the list of charts. Choose the line chart, and then click on the down arrow at the right side of the Sparklines dialog box. This will display the Line chart type again.








Create a Dual Axis Chart




Excel can easily create many charts. You can use Excel to graph almost anything. In this tutorial, i will show you how to create a dual axis chart in Microsoft excel using the built-in formulas that are used to create a chart.



1. In the worksheet that you want to create the chart on, click on the chart area on the page of the Excel tool bar. It will open a chart window.



2. Select Insert -> Insert X Axis. You will see an X axis pop up.



3. Click on the X axis. A window will open.



4. Drag the axis label up to where you want it. You will get an option to either add or remove the data marker.



5. If you click on it, you will see a marker that you can add text for.



6. In the graph window, move the second axis to the right place by dragging it.



7. You can now start using this chart. The chart that you created in steps 4 to 6 is called a dual axis chart. It will be different from a normal line chart.














CHAPTER NINE





Print and Distribute




Microsoft excel is a great tool in many ways. However, there is a certain area where you may not know what to do with it. In this chapter, we will be discussing how you can make use of Microsoft excel file to distribute any kind of content online. An Excel spreadsheet is a file that contains spreadsheets. The content that is stored in a spreadsheet is usually cells, formulas, shapes, graphics, and other content. In this article, we will be focusing on how we can make use of the content that is stored in Microsoft excel spreadsheets.



Before we get started, we need to know that there is no magic formula that you can put in an Excel spreadsheet to automatically print it. The data must be formatted in a way that it is printable. The first thing we need to do is to copy the data into Excel. We are going to use this data set because it can easily be replicated.



Next, we need to format the data so that it can be printed. The easiest way to do this is to use Columns to Format – this is what I use to do it and I am sure that you can get this done in less than 2 minutes. The spreadsheet now looks like this:



We can use Column to format all 4 columns. When you do this, you will be asked for the width of each column. We want to print the width as they are all same. The easiest way to do this is to select the column on the right side of the formula bar and drag it to the left until it starts wrapping. Once we hit the right number, select the column again and press Enter.








Set the Page Size




The Page Size is the size of the printout of the document. If the selected Page size is a different size than the printed size, then the whole page will not print. If the size is right, then every part of the document will appear on the page. The setting of the Page Size is the basic setting of the whole size. There are 3 sizes of the Page Size: Standard, Letter and Legal.



How to set the Page Size:




 
 Select “Page” in the menu.




 
 Select Page Size from the list of the Page Size and click the Set button.



The following settings can be set for the Page Size




 
 The width and the length of the page




 
 The position of the paper (top, left, right, bottom, paper type, corner, corner type, rotation, mirror)




 
 The magnification (scaling of the paper)



How to print more than one page of the document:



You can print the first page of the document and then you can print the other pages of the document. Use the “Print” button.



Printing document in a group:



Printing a document in a group is a great way to print many pages in one. Before printing a document in a group, select the pages to print in a group and use the “Print” button.



Before printing, you can use the “Print” button to print only the first page of the document in a group. This feature is very useful when printing the pages from the PDF file. You can add some pages of the PDF document in a group and print the pages. It will save you a lot of paper.








Set the Print Area




There are two methods of setting print groups:



Method 1:



Set the pages in a group by clicking on the page of a group and using the “Set group” button. You can use the “Print” button to print only the first page of the document in a group.



The pages of the group will be printed in this way: The first page of the document is printed, then you can print the other pages.



Method 2:



Set the pages in a group by using the “Set group” button. You can use the “Print” button to print only the first page of the document in a group.








Print Titles, Gridlines, and Headings




With the PrintSetup option you can enable the print options to show the full titles, gridlines, and headers. If the printer is set to “draft”, the options should show up in the print dialog. You can check the print dialog box by pressing the “F8” key.



The PrintSetup dialog and the VBA print option can be found in this section of the Microsoft help center.








Add a Header or Footer




Microsoft excel is a best application to use to add a header and footer to all the sheets. You can also do this in other word processing programs like google docs. But in Microsoft excel it is done in a very easy manner.



1. Click the File Tab, Click Options.



2. From the drop down list click Edit.



3. Click the tab that says Trust Center.



4. Click Trust Center Settings



5. Click the Trust Center Settings button.



6. Click the Edit Defaults button.



7. Under the Excel Options heading on the left side, expand the General heading and scroll down to the sheet tab on the right side of the dialog



8. Click on the View tab



9. Under the Misc heading, check Show Document Title and Check Show Summary under the General sub heading.



10. Click OK to close the settings dialog box.



11. Restart Excel



To add header and footer:




 
 Open the file that you wish to add the title or the footer to.




 
 Press F1. It will open the Help window. Click on the “See Other Microsoft Office Help Contents” link. The option will take you to your Excel help page.




 
 Scroll to the “Adding a header or footer to your worksheet” section. You should see the images with your solution. Click on the links and you will see the images in more detail. See image below.




 
 Click the Apply button, and close the window.




 
 Go back to the excel file. Click the File Tab and click on Edit.




 
 In the opened dialog box, click Options.




 
 Click the tabs, and from the General tab, click on the Change button.




 
 Scroll down to the Sheet tab and select Show document name or title. Select the option you want to see in the bottom right corner.




 
 Click OK. Restart Excel








Adjust Margins and Orientation




You can set the page size manually, before the printing, and print only the first page of your document. You can also use an option to print a specific page from the whole document (printing only the first page). It is used to print only the first page of the document.



How to add a new page to the document:



Select a page in your document and click the “Add” button of the page tab.



Select the page size from the list of the Page Size.



On the next page click the “Next” button.



Use the Page Setup dialog to specify the orientation, magnification, the position of the paper. To add a new page to the document, you can use an option to print only the first page.














CHAPTER TEN





Chart Options




“I have this chart in Excel that has different data sets. I want to plot different data sets on the chart (not the whole line, just the data within the data set) I know I have to use two different x axis but can’t find anything that works.



My data is in x-axis1 but I want to plot it against the x-axis2(I want to get the data points in axis 1 and place them on the second axis).



Here is the code I have:



=IFERROR(INDEX(A:A,SMALL(IF(ROW($D$2:INDEX(D:D,MATCH(”z”,D:D))+1)=SMALL(INDEX(A:A,MATCH(”z”,A:A),MATCH(”z”,C2:C),0),FALSE),0)



So basically I’m basically getting the next value that matches “z” in the data and putting that in the A column.”



Try:



=IFERROR(INDEX(A:A,MATCH(”z”,D:D)),”)



Or use “x” instead of “z”.








Column




You can use either an Excel formula or the MATCH() function. It will need to be entered into one column and read into the other.



=INDEX(Sheet1!$B$2:$B$7,MATCH($B6,Sheet1!$A$2:$A$7,0))




 
 The =INDEX() formula looks up the value in the list in column B and finds the correct row.




 
 The MATCH() function finds the row where the value in column B matches a value in column A.







	
Line





“I have an excel file in which there are different columns of information. My requirement is to have a line for each type of information in every column, similar to how Excel treats different types of information in a column. For example, say I have the below table



There is a column where it is shown as Date. A column which shows the type of information (A: Information, B: Reference, etc)



There is a column where there is data. This is the column where I want to have a line for each type of information. For example, the line for Date would start from A1. The line for Type would start from B1. And the line for Data would start from C1.



This would help when adding new information. I can start a line of information right away, without creating a gap in the line where my new information goes. The idea is to have separate lines for Type, Date, and Data. Is there a way I can have this?”







Here’s how to do it.




 
 If your data in the table starts in column A, then set the following options in the Formula Bar (ctrl+shift+F11):



Type: =VLOOKUP(A1;$A$1:$B$3;1;FALSE)



Date: =VLOOKUP(A1;$A$1:$B$3;2;FALSE)



Info: =VLOOKUP(A1;$A$1:$B$3;3;FALSE)



Data: =VLOOKUP(A1;$A$1:$B$3;4;FALSE)








 
 The resulting formula will be:



=VLOOKUP(A1;$A$1:$B$3;1;FALSE)&”|”&VLOOKUP(A1;$A$1:$B$3;2;FALSE)&”|”&VLOOKUP(A1;$A$1:$B$3;3;FALSE)&”|”&VLOOKUP(A1;$A$1:$B$3;4;FALSE)




 
 You can change that to:



=VLOOKUP(A1;$A$1:$B$3;1;FALSE)&”|”&VLOOKUP(A1;$A$1:$B$3;2;FALSE)&”|”&VLOOKUP(A1;$A$1:$B$3;3;FALSE)&”|”&VLOOKUP(A1;$A$1:$B$3;4;FALSE)




 
 To save having to enter these formulas into each cell you can put them in one single cell, and use:



=INDEX(A1:A4;MATCH(”*”;A1:A4;0);MATCH(ROW(1:4);A1:A4;0))




 
 Or even:



=INDEX(A1:A4;MATCH(”*”;A1:A4;0))&”|”&INDEX(A1:A4;MATCH(”*”;A1:A4;0))



But it really depends on what you want to do with that. I personally use the latter, because it is easier to update the formula.







	
Pie





A Pie chart is a quick way to organize data. For instance, there are three states where you can vote: red, green, or blue. Then, on a Pie chart, you can organize the data so you can see if someone voted blue, or red, or green. You can also use a Pie chart to organize and represent a set of data that is being presented in an easy way.



There are several different ways you can present data with a pie chart:




 
 By color




 
 By shape




 
 By color and shape




 
 By size



Using a Pie chart, you can be more organized.







	
Bar





“I would like to write a macro in Microsoft Excel that will allow the user to input text into a text box then search through a table, column by column until the text box is blank or the cell is highlighted. When the cell is found, the user presses enter and the corresponding cell in the table is highlighted and the data is copied and pasted to a second excel file.”




 
 Try this:



Sub FindAndCopy()



Dim vRng As Range, rCell As Range



Dim rTemp As Range



Dim rResult As Range



Set rTemp = Sheets(”TEMP”).Cells(1, 1)



Set rResult = Sheets(”NEW_TABLE”).Cells(1, 1)




 
 If rTemp.Text <> ” Then



For Each vRng In Sheets(”TEMP”).Range(”A1:A12”)




 
 If vRng.Text = rTemp.Text Then



rTemp.Offset(0, 1) = rTemp.Value



Exit For



End If



Next vRng



This iterates through all the text cells in the range “A1:A12” from row 1 of the sheet “TEMP”. This means we can get the text in column A for all the cells (and not just the cells we are currently in).



If the text in column A of the range vRng (i.e. the text in column A of the cell that we are currently in) is equal to rTemp.Value, we copy the range (including the “TEMP” header row) to the destination sheet “NEW_TABLE”.



Note the “NEW_TABLE” sheet needs to be selected before this line. Otherwise, the copy will just overwrite the “NEW_TABLE” sheet and delete all the text. The sheet “NEW_TABLE” also needs to be selected (or the range copied) before pasting the data.



If we want to modify the value in the source (for example, if there is another column B in the original table) we could create a new range “B:B” in the destination “NEW_TABLE” sheet, and loop through that to copy the data into the right cells.



Here’s some code that might help you (run from the worksheet where you want to copy the text data):




 
 Sub CopyText()



‘Set the target sheet, cell range (using this) and paste (if necessary)



Dim ws As Worksheet



Set ws = ActiveSheet







Dim vRng As Range, vTemp As Variant



vTemp = Array(”TEMP”)



Set vRng = .Range(”A1:A12”).Value



End With







vRng = ws.UsedRange.Value



If vRng.Count <> 1 Then



MsgBox “Cells in the range “ & vRng.Address & “ are more than one cell”



GoTo EndOfSub



End If







Dim rTemp As Range, dest As Worksheet



Set dest = Sheets(”NEW_TABLE”)



dest.UsedRange.Clear



Set rTemp = dest.Range(”A1:A12”)







If vRng.Count = 0 Then GoTo EndOfSub



vTemp = vRng.Value








Area




“I am working in a excel file with several sheets.



I would like to apply a custom formatting to an area of the Excel sheet. The area is defined by four cells, from A5 till F5, excluding all of them. The custom formatting works fine, but the formatted range is not dynamic and doesn’t work if the user adds a row to the sheet. I would like it to apply to every sheet.”



Format Range is only applicable to a currently selected range of cells. Your cells aren’t selected, so this won’t work.



However, if you know in advance that the cells in question will be always be the 5th row, you could select that cell and then apply a custom format:




 
  ‘ set the format



 With Range(”A5”)



 .Font.Bold = True



 .Font.ColorIndex = 37



 .FormatConditions.Add Type:=xlCellValue, Operator:=xlEqual, Formula1:=”=5”



 .FormatConditions(.FormatConditions.Count).SetFirstPriority



 .FormatConditions(1).Interior.ThemeColor = xlThemeColorAccent6



 End With



I like the idea of using the FormatRange option but it doesn’t work if the cell’s contents don’t change.



It seems the most reliable way of doing this would be to create a range of cells that are always the 5th row, then apply the formatting. For instance:




 
 Sub Button1_Click()



 Dim rng As Range



 Dim cl As Range




 
 For Each cl In ThisWorkbook.Sheets(1).Range(”A5”)



 Set rng = ThisWorkbook.Sheets(1).Range(cl.Address)



 rng.FormatConditions.Add Type:=xlCellValue, Operator:=xlEqual, Formula1:=”=5”



 rng.FormatConditions(rng.FormatConditions.Count).SetFirstPriority



 rng.FormatConditions(1).Interior.ThemeColor = xlThemeColorAccent6



 Next



End Sub



I haven’t actually tested this, but it should give you an idea how to approach it.








XY (Scatter)




“In the rightmost column I have the corresponding cell values that I have inputted into the graph. My question is, how can I create a scatter graph using all these values? I would like to graph all the values (the Y axis) on the same chart. I have tried importing the values into a pivot table and the pie chart was not the best way to go.”



I would take your values and add them to a pivot table. Set the data source to =Data!A1:A100 (assuming A1 is your first value), click on the Column Header in your pivot table, and click on Show Me



You can then use this as your data source for your scatter chart. Simply right-click on the pivot table, click on Select Data and choose your chart data and chart area.



If you want to have more control over the formatting of your chart, you can go to Insert, Scatter chart. Create the chart you want, and drag and drop the pivot table onto it. You can then format your graph as you wish.








What is stock in Excel?




Stock







Let’s assume that you have a spreadsheet and you have a few rows and a few columns and you want to find out



How much stock do you have?



So, the stock is the amount of goods



In the particular cell or row or column. Now in order to find out the stock of a particular product, let’s say it’s milk; You can go to the “Data” ribbon







	
Surface





“I am doing simple calculations (expanding/contracting) in Microsoft excel 2021. I know that I can do this in several ways, but in most of them it is possible to go back and edit the formula, and I was just wondering if there is any way to go back and edit a formula that you have just calculated once. For example I type in formula A1=B1 and hit enter, in that moment I can change the formula to be A1=B1+1 and then it will automatically change and put the result in A1.



What I was wondering if you know of, or if you can think of any way, that I can automatically expand/contract formulas that are not the same. For example. Lets say I want to calculate A1=B1, A2=B1-10 and A3=B1+50. If I type in the formula for A1=B1 it does that and A2=B1-10, but A3 is still =B1+50. If I type A3=B1+50, then when I hit enter it does A1=B1, A2=B1-10 and A3=B1+50. Is there any way to do this without having to change it all the time”?








 
 Press Alt+F11. That’s the shortcut for “Edit the selected formulas.” You can then change all of them.



What if I want to automatically expand/contract formulas that are not the same?



There is an option for that:




 
 Select the first cell in your formula




 
 Press F2 to Enter the formula, then type it




 
 Press F2 again to Enter the formula, then press Enter



You will see it auto expand.



Repeat steps #1 & #2 until you have all your formula listed, then press Enter on the last formula.



Note: If you are adding a column above or below to your current formula, add the formula to the top or bottom of the list.




 
 If you are using columns next to one another you can use: =$A$1, =$B$1, $A1, $B1


















CHAPTER ELEVEN





Additional Chart Elements




The additional chart element includes all the elements that are specific to the chart element. The additional chart element contains the following sub-elements:




 
 Sub-element name




 
 Description




 
 Additional Chart Type



The type of chart to be added. This can be the type selected from the Charts section.




 
 Additional Chart Title




 
 The title of the chart




 
 Additional Chart Labels




 
 The labels added for the chart



Additional Chart Axis




 
 The axis on which the axis labels are added




 
 Additional Chart Data Points




 
 The data points that are added




 
 Additional Chart Series




 
 The series added to the chart




 
 Additional Chart Values




 
 The value that is added for the value of each data point



The additional chart element can be called on any Chart component. In order to add additional data to the chart, the chart should be first opened for edit. In this case the entire chart should be edited and not any single data point. Figure 3 shows the additional chart element for Line chart. It can be used to add a description for the chart along with a title.



FIGURE 3: Additional chart element – line chart



Example: Line Chart of Year 2018. The table below shows an example of adding the chart with additional data in Microsoft excel.



Additional chart elements: line chart




 
 Sub-element name




 
 Description




 
 Additional Chart Type




 
 Line



Additional Chart Title




 
 Year 2018 Line Chart



Additional Chart Axis




 
 Y-axis



Additional Chart Data Points



3.0



6.0



6.5



6.2



3.0



9.8



6.0








 
 Additional Chart Series



0.0



6.0



3.0



5.0



5.0



5.0




Data Labels




Is there a way to change a value (i.e. text inside a cell) in a Microsoft Excel cell which is displayed as a Label in another cell.



Excel has the ability to display values in the following ways (i.e. as text or numeric)



=B13



=B13



=$B$13



The only information I have found in the excel documentation is how to change a value so that it is read as a text (i.e. =TEXT(B13). This is not an easy job (at least in a macro sense) because I cannot use a number and then try to convert it back into a text.



Here is a simple example:



I found a way to do this in a macro by first creating a function (in this example, the macro is in B2) and then creating a string in cell B2 which will display the formatted number in a label




 
 Function MyNum(v)



Dim MyText As String



MyText = Format(v, “0”)



MyNum = MyText



End Function



(MyNum is the function name in B2)



In the cell next to MyNum(B2), I used the following formula



=MyNum(B2). This is a way to display the formatted number, as text, in a cell which is itself a label.



You could add a messagebox that is triggered when someone does a =B13 to see the result. You could also take the other approach (set .TextFormat to 0). But note that this has an impact on the performance of the calculations because the whole spreadsheet has to be recalculated.



I’ve had a lot of luck using these functions to turn cell numbers into text:




 
 Function CellToText(cell_number As Long) As String



cell_text = Format(cell_number, “dddd, mmmm dd yyyy”)



End Function




 
 Function NumberToText(cell_number As Long) As String



cell_text = cell_number & “ days”



End Function



The “NumberToText” function will only work if the cell is formatted as a number. This can be useful when you want to show the value without the formatting. The “CellToText” function will turn the text back into the number with the appropriate formatting.



You can take the cell_text value and put it into your cell to perform your own formatting if needed.



Another good option would be to use the Text Function. This is just a better method than trying to format it yourself.








Data Table




If it’s a single row of data you can do something like this:




 
 Option Explicit



Dim strRow As String



strRow = “E2:F2”



Do Until Sheets(1).Range(strRow).Value = ”



Sheets(1).Range(strRow).EntireRow.ClearContents



Loop



If it’s multiple rows you’ll need to do some more work:



Dim strSheet As String



strSheet = “Sheet1”



With Sheets(1)



For i = 1 To .Cells(.Rows.Count, “A”).End(xlUp).Row



 If .Cells(i, “A”) = “E2” Then



 .Rows(i).ClearContents



 End If



 Next i



 End With



Or, a simpler way if your data is always going to be in row 2:



Dim strSheet As String



strSheet = “Sheet1”



Sheets(1).Rows(2).Resize(1).Delete



Note: The last two pieces of code rely on the sheet being in the active workbook, so make sure that’s the case first.








Trendline




Trendline is the best way to view the actual and long term changes in time intervals with the help of the visual trendlines. Trendline analysis is mostly used in financial services. In this article, you will learn how to add a trendline to your excel in just a few seconds. You can easily add trendline to your Excel worksheet by simply dragging the trendline from the data window to the sheet. The trendline will connect the data points within the data window.


[image: ]



Here’s how to add trendline to Excel in few seconds.



1. Open the excel and choose any one of the cells where you want to add trendline.



2. Then click on the tab named data



3. Now click on the Trendline icon



4. On the left side, you’ll find the data range of the column where the trendline needs to be plotted. In the example here, the graph needs to be plotted on column A. Click on the trendline icon (You can also find it at the top left corner)



5. The chart will be populated with the data that you selected on step 2. If you don’t like the trendline, you can use the settings icon and customize it according to your needs. In the example, I clicked the settings icon (You can also find it at the top left corner)



6. There you have it, your trendline in Excel.



You can always edit the trendline (make it red, green, blue, etc) by clicking on the tab settings (or the customize trendline button).



You can also plot the trendline on different sheets by changing the name of the sheet in the sheetname field. For example, to plot the trendline on sheet2, you can use the name sheet2


























CHAPTER TWELVE





Intermediate Formulas





What is Intermediate Formula?




Here is a brief explanation about what “intermediate formulas” are and what they do. In brief, they have three elements: Sum of Values, Indirect Function, and Indirect Formula.



Let’s begin with what sum of values is. A sum of values is a mathematical calculation that is performed by using the SUM function in Excel. It calculates the sum of a set of values.



Consider the following sample.



Step 1: In cell A1, enter a formula to calculate the sum of all the values in the list of values in column A:



Step 2: Press the F2 key to invoke the “intermediate” or “sum of values” mode of Excel. The result would look like this:



Step 3: Click on cell A1 to place it in the sum.



Step 4: Now click on cell A2. You will now see the result.



If you don’t want to follow the steps manually, you can also just press the F9 key to enter the sum mode of Excel.


[image: ]




 
 Why is this important? Let’s consider the next example.



Example: What will the sum of values be in this scenario?



What is the sum of values in cell A1 if we add another 10 (e.g. 20) to the end of the list in cell A2? The cell in cell A2 must be highlighted in order to see the values entered in the cells below it.



Step 1: Click on the F9 key to enter the sum mode of Excel. Click on cell A1.



Step 2: Click on the F2 key to switch back to the normal mode.



Step 3: Put a new value of 30 in cell A2.



Step 4: Click on cell A1. You will see that the cell has now changed to read 30.




 
 How do we create an indirect function? A function is a set of values in an Excel cell or a formula that calculates a value based on the values in another cell or set of cells.



Let’s begin with a very simple indirect function. Consider the following example.



Step 1: In cell B2, enter a formula that calculates the value of 4 x 2. i.e. B2 = 4 * 2.



Step 2: Click on the F9 key to enter the sum mode.



Step 3: Click on cell B2. You will see that the formula you entered in step 2 has been calculated and returned as a value of 8.



Step 4: Click on the F9 key to enter the function mode.



Step 5: Click on cell B2. You will see that a box has appeared. The value displayed in the box is ‘=4*2’.



When we enter the formula in cell B2, Excel calculates the values in cell B2, multiplies them (in this case 4 and 2) and then stores this in cell B2.








Absolute References




The absolute reference technique is used when a cell contains a reference to a range of cells in a different worksheet.



The following example illustrates this process.



=Sheet1!A2



The absolute reference is Sheet1!A2, while the relative reference is A2.




 
 If Sheet2 has cell A2 also set to Sheet1!A2, Sheet2!A2 will reference the absolute reference in Sheet1. The absolute reference can only contain a number of cells, but if a relative reference is not available, this can be overcome by concatenating different parts of the sheet name (in this example Sheet1!A1).








Name a Cell or Range




This macro allows you to automatically select a specific cell or range of cells. A message box is displayed in which you are asked



The cell or range to be renamed has to be selected before you can rename it.



To rename an entire range:




 
 Select the cells you want to rename.




 
 In the Data ribbon, click the Rename button (to the right of the cell name).




 
 Type the new cell or range name.




 
 Click OK.



To rename an individual cell:




 
 Select the cell you want to rename.




 
 Click the Data ribbon, and then click the Rename button (to the right of the cell name).




 
 Type the new cell or range name.




 
 Click OK.



To rename a cell that is part of a table:




 
 Use the table name and cell name to rename the entire table, or.




 
 Click the cell you want to rename, and then, in the Data ribbon, click the Rename button (to the right of the cell name).




 
 Type the new cell or range name.




 
 Click OK.







Notes:




 
 If you want to change the name of multiple cells in a cell range, use the Paste Name feature instead of the Rename feature.




 
 If you choose to rename a cell and have Excel warn you about changes that might be made to data that is linked to the data that you are trying to rename, then choose Yes when you are prompted to save the change. If you have linked data in the new name, then there may be errors. Choose Yes to save the change, then try renaming the cell again. The change should still be accepted.




 
 Renaming a cell or range doesn’t affect any formulas or formatting applied to the cell or range. You can easily change the formula and format of the cells you’ve changed.




 
 You can only Rename a cell or range if the cell or range is currently selected.



if you would like to make the selection:



Sub Select_Range()



Dim selected_cell As Range







To ‘make a selection and return the object reference of the selection:



Set selected_cell = Application.Selection



‘If you did not select anything return “No Selection”



If IsEmpty(selected_cell) Then



MsgBox “No Selection made”



‘If the selection is empty, return nothing.



Exit Sub



End If








Reference Other Worksheets




You can refer any other work sheet which has values to a reference work sheet.



To do this;




 
 Go to Home tab




 
 Then, select the sheet which you want to use as the reference and




 
 Click the button on the far right




 
 A blank work sheet will open




 
 Now you can select a cell on the new sheet and copy values



This is not how you would copy sheet name instead you would copy cell name in which case you do not need to have a unique name. It is also recommended to use the name of the sheet instead of the cell names.



After you copy values, make sure to click the cell name, else the values will be copied to the referenced cell. This feature is also useful in copying values of specific column only or specific row only




 
To select a column or row:





 
 click the sheet tab and then on the first row click in the column you want to copy values from




 
 Select from the drop down menu in the box and select the column or row



Note:You will get a warning if you copy non existing values.



If you want to copy values from the first row of the referenced sheet to the last row on your sheet;




 
 Select the column where you want to copy and then the range in which you want to copy




 
 Now select the range you want to copy from the referenced sheet




 
 After you copied values, you have to paste the values to where you want them to be.



To paste values:




 
 Go to home tab




 
 Select Paste option




 
 Click in the cell where you want to paste the values.




 
 You can select PasteSpecial option




 
 Select PasteValues from the drop down menu



To paste in specific cell range:




 
 Select the range where you want to paste and from the Paste options menu




 
 Select PasteValues




 
 Copy and Paste Values








Reference Other Workbooks




If you open a workbook from an archive folder that has a subfolder called ref and the same subfolder that has the subfolder workbook.xls then it will be listed under the name Reference Other Workbooks in Excel. Note that if there are any sub-folders in the workbook and in the other folder then the first folder that has a workbook in it will be listed.



Some Excel users have the option to select which Excel documents are available to open in Excel itself. In the case of a user without the option to control the files which are opened in Excel, the user would have the option to send the Microsoft Excel files to Microsoft Excel on a different computer or device that has the option to control the files opened. To do this, the user can open a file in Excel that can control the files opened.



An example of this is that a user can open a file named file.xlsx that will allow that person to control the files that open in Excel. The user can then open a different file and send the file to the computer that they wish to control the files opened.



To start:



The user selects the file that the user wishes to open in Excel. When that file is opened, if the file has control options, the user can select which files open in Excel. To do this, the user opens the file and the user selects the option to add to the Microsoft Excel settings. This will add the file in the Microsoft Excel settings and will open the file in the same manner that an open workbook will be opened. If a user wants to open the file in a new window in Excel, they can also do so.



If you have to send a file to a user that controls the files opened in Excel, the user may not be able to control the file that you sent them to them. To make sure the file that is sent to the user will open in the same manner as the original file, you can include the file with the add to Microsoft Excel settings option. When the file is sent to the user, it will open in the same manner as if the user opened the file directly. To learn more about how to send files to a user that controls the files opened in Excel, see How to send a file to a user that has control of the files opened in Excel.








Concatenate Text




“I have a lot of lines like the following, some are on one line, some are on more than one line, how can i concatenate and save to a new text file? I need the result to be in the same excel file, so i need to open the file and then do the concatenation.”



What you are looking for is the formula:



=CONCATENATE(A1,” “,B1,” “,C1)




 
 You would enter this into cells you need to concatenate, and once done you would need to highlight all cells that you want to concatenate




 
 Go to data tab and then concatenate.



If you wish to merge columns A, B and C into column D then the formula would be:



=CONCATENATE(A1,B1,C1)



I found a solution here, just in case someone else is looking for a solution:



Sub CopyConcatenate()



Dim MyWb As Workbook



Dim MyRng As Range



Set MyWb = ThisWorkbook



Set MyRng = MyWb.Sheets(1).Range(”A1:B5”).



MyWb.Sheets(1).Range(”D1”).Value = MyRng.Formula



End Sub



I’m just using Sheets(1) but you could change that if you want. Then you have to highlight the rows that you want to concatenate. You can’t copy and paste, just highlight then run the macro




Payment Function




Payment Functions Workbook in Microsoft excel is a macro which allows you to calculate your payment. For every week the loan value is increased by the weekly interest rate the loan value is also reduced by this amount. Every payment the loan is reduced by the monthly interest rate. The total loan value when the loan is paid off is automatically calculated for the last payment.



Payment functions in Excel are one of the functions that will enable you to perform basic calculations on a spreadsheet. If you’re interested in learning how to use these functions, you can explore various functions that are available in the standard functions of the Microsoft Excel. When it comes to payment functions in Excel, it is important to have an idea about the various functions and their usages.




What are the Payment Functions in Excel?




There are several functions in Excel that are known to be the payment functions. The payment functions allow you to manage money and expenses. As a standard function, it contains several calculations like: calculation of interest and payment of loan, payment of bills, calculating the amount of cash received, calculation of loan, calculation of profit and loss, and calculating the net income.



If you are looking for a way to manage the payments in a given period, you can use a formula to calculate the interest due or other expenses, which can be done easily. It will also help you to calculate and manage different functions, which are related to money.



Let us look at some basic payment functions in Excel. It can be considered as one of the popular and easy to use functions. When a spreadsheet user wants to find out how to calculate the payment of a loan, we use the Excel functions to calculate and manage the payment.



What are the Functions for calculating interest and Payment?



When we calculate the interest and payment, the formula that we use is:



=Calc(“interest due”,”period”)



=Calc(“payment”,”period”)



Both of these functions are used to calculate the amount of interest and payment. Let us try to understand the meaning of each of these functions:




 
 Calc(“interest due”,”period”): The Calc function allows us to calculate the interest due, based on a specified period and the specified date. It calculates the amount and the interest due to a specified date and period.




 
 Calc(“payment”,”period”): The Calc function is used to calculate the interest due on the loan. It is used to calculate the amount of interest payable on the loan and will calculate it using the specified time period.



How to calculate the Payments and Interest in?



The Excel formula for calculating interest and payment can be written as:



=Calc(“interest due”,”period”)



=Calc(“payment”,”period”)



The values should be entered into the above cell. We will enter the values in the cells H2, H3, H4 and H5, in order to get the accurate interest and payment.



To calculate the interest and payment, we will use the Excel function Calc in the above formula.








Date Functions




In Microsoft excel, there are various built-in functions to compute different functions like:



a) Date and Time: DATE, DATEDIF, TODAY, TODAY()



b) Percentages: PERCENTAGE, PERCENTRANK, PERCENTILE



c) Financial: EXP, LOG, LOG10, LOG2, LOGEST, POWER, PRODUCT, QUOTIENT, ROUND, ROUNDDOWN, ROUNDUP, SIGN, SQRT, SQRTPI



d) Data manipulation: MAX, MIN, MAXA, MINA



e) Text manipulation: ISNUMBER, ISBLANK, IFNA, IFNAE, IFNBE, IFNBH, IFNB4, LEN, SOUNDABC, LENB, LENPRD, LEN, TEXTJOIN, LENB, LEN, LEN



 f) Arithmetic: AVERAGE, AVERAGEA, AVERAGEIF, AVERAGEIFS, AVERAGE, AVERAGEA, AVERAGEIFS, AVERAGEIF, AVERAGEIFS, COUNTIF, COUNTIFS, COUNT, COUNTA, COUNTIFS, COUNT, COUNTA, COUNTF, COUNTABS, COUNTIF, COUNTIFS, COUNTIF, COUNTIFS, COUNTIF, COUNTIFS, COUNTA, COUNTIF, COUNTIFS, COUNTA, COUNTIFS, COUNTIF, COUNTF, COUNTABS, ISNUMBER, ISBLANK, IFNAE, IFNBE, IFNA, IFNBE, IFNAE, IFNA, LEN, LENB, LENPRD, LEN, MAX, MIN, MAXA, MINA, PRODUCT, QUOTIENT, ROUND, ROUNDDOWN, ROUNDUP, SIGN, SQRT, SQRTPI



But there are more than 100 of them in excel.



Now, while exploring these functions, I found one interesting function named =IFNAE (In fact, you should read that in details to understand the real purpose). It gives you one Boolean value (True or False) which tells you whether there is a null value or not in the cell or cells which you gave as a parameter.



There is a COUNTIFS (or COUNTIFS as well) formula in Excel. It counts all the cells of the first argument that meet the requirements in the second argument. In your case that would be the second argument that is the criteria you define in the first argument. In your case you have 1 in the first argument and 0 in the second. It will return 1 (true).




 
 If your range is A2:A23 and you want to count all cells that have a value of zero then: =COUNTIF(A2:A23,0)



The result will be 23.




 
 If you want to count the number of cells with zero values but not including the range A2:A23 then use this instead: =COUNTIF(A2:A23,0)-COUNTIF(A2:A23,”*”)



The result will be 23 - 1 = 22








Display Worksheet Formulas




Excel doesn’t have an equivalent to VBA. However, you can still do some really nice things using conditional formatting and a small script. For example, in a simple sheet with a single row, you can use Conditional Formatting. Click on the cells that you want to format and you’ll see a button at the top-right that says “Format cells based on criteria” Click that and you can make display sheets:



You can make rules that are any of the following:




 
 Apply to a Range: choose a whole range of cells




 
 Apply to a specific value: this will be a single value in the format string.




 
 Apply to a specific text: this will be in the format string.




 
 Custom formula: this will be evaluated in the Format Cells dialog.



It may not be obvious at first how to use this.



For example, you can enter a formula that finds the index of the cell with the highest number. For example:



=INDEX(A:A,MATCH(1E+99,A:A) will return the cell that has the highest number.



Then you can apply the format to this cell and choose a specific value. For example:



=INDEX(A:A,MATCH(1E+99,A:A). Now just return the number 1E+99.



But there’s more! You can go into your “Format Cells…” dialog and select “Evaluate for the formula” which will change your formula into an VBA code like this:



If (ActiveCell.Value = 1E+99) Then 1



This will run when the “Evaluate for formula” button is clicked.



Obviously you could use this in more complex formulas.



But it’s not necessary to use VBA for every task. You could have a script like this:




 
 Sub FormatCells




 
 Dim sh As Worksheet: Set sh = ThisWorkbook.Sheets(”Sheet1




 
 For Each cell In sh.Range(”A1”, sh.Range(”A” & Rows.Count).End(xlUp




 
 Cell formula = If(cell.Value = 1E+99, 1, ”







Now you have no need to worry about formatting the cell - all that’s done automatically when you set the cell to have the value 1.



The same technique could be used to set the text to just the name of the person who made the sheet, or even just a date, or all the values of the column with the highest value.


















CHAPTER THIRTEEN





Manage Data




Basically you need to put the data into a table, create a query using an INSERT statement, run that query (not the table), and then save your workbook.







	
Export Data





To export data in the following fields:




 
 Code




 
 Description




 
 Type




 
 Subcode



Go to Data >> Get External Data >> From Other Sources



Go to Add external data >> choose your data source.



And then import them.




 
 If you need, you can use VBA, use this code:



Public Sub Import



‘ Open the file and append new data to its existing data.



Dim objApp As Object



Dim objDoc As Object



Dim objRng As Object



Dim strDoc As String



Dim objSel As Range



Dim strFile As String



Dim strDir As String



Dim col As Long



Dim objFld As Object



Dim strCol As String



Set objApp = CreateObject(”Excel.Application”)



‘Set objApp = CreateObject(”Excel.Application”)



strFile = “c:\Test.xls”



objApp.DisplayAlerts = False



objApp.Visible = False



strDir = “c:\”



Set objDoc = objApp.Workbooks.Open(strDir & “\” & strFile)



strDoc = objDoc.Worksheets(”Sheet1”).Range(”B1”).CurrentRegion.Value



objDoc.Close savechanges:=True



objApp.DisplayAlerts = True



‘ Open the file with “Save As” and set the file name, and then import the data.








Import Data




Below this step you will see that it has exported the data into a Excel Spreadsheet. So we will take the necessary steps in order to import the data into your MS SQL Server database.




 
 After clicking on the Import button you will be prompted to give the location of your imported file, i.e.




 
 Once we will enter the location of the data file(File Name is ‘CITYDATA01’ ) the next screen will look like this.



Note: We have given the location of the file as ‘C:\excel\DATA’




 
 Now click on Import button and you will be able to import the Excel file.




 
 Now you will get a screen with a message indicating that the import has successfully completed.



But this time we are not going to take the path to the Excel file, instead we are going to take the data directly from the database i.e.




 
 Once we have given the path to the excel file, we need to open a new session of MS SQL Server Data Tools, this is going to be like the one shown in the above image. In order to open a new instance of MS SQL Server Data Tools, you will need to go to Start -> type in MSSQLSERVER and then click on the MSSQLSERVER icon as shown in the image below.




 
 Now when we open a new MS SQL Server Data Tools instance, we will be prompted to give the name of the Database and the server on which our database resides.



So by giving the name of the database ‘CITYDATA01’ you will get to know that we are in the right Database.



You will need to give the connection name to connect the database with the file and then click on OK.




 
 Now click on Open and your Import Wizard will appear.




 
 Now go to the first tab and you will be able to select the Excel file and upload it.




 
 And lastly, click on Go.



Once the process has been completed you will be able to see a message indicating the status of the import as well as the progress made by the import. Once we click on OK and close the Data Import Wizard, you will be prompted to re-open the database from where the import will be executed.







If we want to create a new table from where the data was imported, we will follow the steps below.




 
 Go to the Object Explorer as shown below, then Right click on Tables node and select New Table from the context menu.




 
 Now name the table ‘CITYTRANS’.




 
 Click on OK.




 
 Go to the Object Explorer again, this time you will see that a table has been created. You will be prompted to select from where the data has been imported.




 
 Select your CityTable file.




 
 Click on OK.



Let’s update an existing table.




 
 Go to the Object Explorer and Right click on tables node and select Update Table from the context menu.




 
 In the next window, enter the table name as ‘CITYTRANS’ and the table has been updated successfully as shown below.



We can also sort the records based on a column. We can even filter the data based on any other column that is present in the CityTable file.








Use the Quick Analysis Tools




The Quick Analysis Tools require an excel file with the company name (and some numbers) in one column and the years the company started in another. Then in the cell with the date, you will have a little tool where you can select the company name and see what happened on that date.



The other important thing you can do to help with this is to take the Excel file that contains the Company Information and add each company’s Name and all their dates in a separate worksheet, then sort the worksheet by date ascending, so that you know which companies started first and thus have the most complete data.



A Quick way to do this is to start by doing the following:




 
 Make sure the Company File is open in Excel (I’m assuming you are familiar with how to do this).




 
 Open the file that has all the companies you want to analyze.




 
 You will probably have to open it in Microsoft Excel, just click File > Open, select the company file, and open it.




 
 Then, start creating a new sheet that has just the information about the company you want to analyze in it, for example: “Apple”.




 
 After you have a sheet titled “Apple”, double click the Apple tab to create another new tab in the worksheet (make sure that there are no sheets other than this one).




 
 In the top left corner of this new tab, in cell A1, add “Company Name” in the Text cell.




 
 On the top right corner of the Company tab, in cell A2, add the year of the company in the Text cell.




 
 Double click on the tab Company and type in all the information that you want to be in the table.




 
 Click on the tab Data and then click on the Date cell and click on the down arrow next to it and select Date.




 
 Click on the tab Company and click on the date cell and click on the down arrow next to it and select a specific day of the year.




 
 Copy and paste the information in your sheet that has all the dates, one in each row (but leave the Company name).




 
 After that, do the same for all the other companies you want to analyze.



Now you should have a Worksheet that has all the dates and company names and everything that you want. The next step is to open the file that has the company’s financial data.




 
 Add the data to the worksheet




 
 In the beginning of this section, I mentioned that this file has dates and sales for each company.




 
 First, copy the data from that file.




 
 After that, start by double clicking on the tab Company to open the Company tab in the spreadsheet.




 
 In the top left corner of the Company tab, add “Company” in the Text cell.




 
 Click on the tab Data and then click on the Sales cell and click on the down arrow next to it and select the Sales amount from the drop-down menu.




 
 Click on the tab Company and click on the Sales cell and click on the down arrow next to it and select the Sales amount from the drop-down menu.




 
 Click on the tab Company and click on the Sales cell and click on the down arrow next to it and select the Sales amount from the drop-down menu.




 
 Copy and paste the Sales Amount data to the Sales cell.




 
 Click on the tab Company and click on the Sales cell and click on the down arrow next to it and select the Sales amount from the drop-down menu.




 
 Copy and paste the Sales amount to the Sales cell.




 
 Click on the tab Company and click on the Sales cell and click on the down arrow next to it and select the Sales amount from the drop-down menu.




 
 Copy and paste the Sales amount to the Sales cell.




 
 Click on the tab Company and click on the Sales cell and click on the down arrow next to it and select the Sales amount from the drop-down menu.




 
 Copy and paste the Sales amount to the Sales cell.




 
 Click on the tab Company and click on the Sales cell and click on the down arrow next to it and select the Sales amount from the drop-down menu.




 
 Copy and paste the Sales amount to the Sales cell.




 
 Click on the tab Company and click on the Sales cell and click on the down arrow next to it and select the Sales amount from the drop-down menu.




 
 Copy and paste the Sales amount to the Sales cell.




 
 Create your formula. This section starts with the first formula in the file.




 
 The first formula is a formula that shows the total amount of Sales in the worksheet.




 
 To be able to see the formula, you have to press Ctrl+1




 
 Type the formula into the next column in the spreadsheet








Outline and Subtotal




“I’m using Excel to manage a long series of projects, and I’m looking for a way to make each one ‘look’ like a normal report. I have a header row (for the project title, description, contact info, etc.), and I also have a ‘subtotal’ column at the bottom that lists the total cost of each project.



The total cost is a combination of the project cost and a ‘profit/loss’ line. Here is an example of how my spreadsheet looks.”



In the picture above, I would like to be able to make Project X’s ‘outline’ appear as the green cells above it. As a result, the subtotal at the bottom would be increased by Project X’s subtotal.




 
 You need a hidden field on your table and a VLOOKUP function. Here’s a sample with a dynamic table you can copy/paste:




 
 You can also get more information from this tutorial: Using VBA to sum and sum if VLOOKUP function



In your specific case, I would create a hidden field on your “Overview” sheet to store the result of the sum. Then I would use a module to calculate the “Summary” (subtotal) automatically:




 
 Private Const TOTAL_MONEY_FIELD_NAME As String = “TOTAL_MONEY_FIELD_NAME”




 
 Public Function CalcTotalMoney() As Long



Dim sheet As Worksheet



 Set sheet = ThisWorkbook.Worksheets(1)



CalcTotalMoney = sheet.Shapes(TOTAL_MONEY_FIELD_NAME).Text &



Application.WorksheetFunction.vlookup(”TOTAL_MONEY”, sheet.Columns(8), 1, False)



And in a cell, you could use it like this:




 
 =CALCULATE(sum(Summary!$F$8:$F$10),Overview!B8)



To make the result of this function dynamic, you can add this macro on the “Overview” sheet:




 
 Public Function CalcTotalMoney() As Long



CalcTotalMoney = Application.WorksheetFunction.vlookup(”TOTAL_MONEY”, ThisWorkbook.Sheets(1).Columns(8), 1, False)







Now you can use this function in the same cell on the “Overview” sheet:




 
 =CALCULATE(sum(Summary!$F$8:$F$10),CalcTotalMoney())







There is no need to add another module for this part anymore, as it is already done by the “Overview” sheet.



And the second example I have provided, is to remove the need for a “Summary” sheet from your Excel template. You don’t need it at all.



To make it dynamic you can add the following macro on the “Overview” sheet:




 
 Public Function CalcTotalMoney() As Long



CalcTotalMoney = Application.WorksheetFunction.vlookup(”TOTAL_MONEY”, ThisWorkbook.Sheets(1).Columns(8), 1, False)



Then use this formula in the same cell on the “Overview” sheet:




 
 =CALCULATE(sum(Overview!$F$8:$F$10),CalcTotalMoney()








Use Flash Fill




Using Flash Fill in Microsoft Excel is an easy way to complete a template on your own without having to pay expensive fees. Microsoft provides a free tool for Excel users. The tool is called Flash Fill. This tool has many more features than free online word templates. In fact, it is almost identical to Microsoft Word’s Auto Fill functionality.




What is Flash Fill?




Flash Fill allows you to complete a template for you using autofill. A template is a collection of text that you can use when filling out forms. Templates are created in the same way as you create any other form – there is no extra work required. Templates also contain all the required information for you to fill out. This makes it easier to start filling in a form without wasting time looking through a form and trying to remember the information you are looking for. Templates can also include hyperlinks which direct the user to a specific form, and even text formatting such as bold or italics.



In addition, templates contain a large number of frequently used fields. The fields automatically populate themselves with the correct information as you start to type. Flash Fill works with many different types of templates, including forms, spreadsheets and other types of templates. All templates are organized into template folders. When you create a new template, it is added to your template folder. A template folder contains several templates. This allows you to find and use the same template as another user.



Templates are created in a very similar way to any other form you create. You select “New” from the templates tab, then choose “Form” from the list. There are three methods of creating a form: a hard-coded template, a template stored on your computer, or a template stored on a website. The first time you create a form it may ask you to choose one of the options.




Creating a New Form





 
 A template is created in the same way you create any other form.




 
 Select “New” from the Templates tab.




 
 Choose the type of template you want, “Form”, then choose which method you want to use.



Note: In the “Use HTML” box you can leave the default of “No”, but most of the templates in the system do allow you to have HTML tags within the form.




 
 If the form is going to contain a large number of fields, you can choose to “Use a pre-formatted template”, which will allow the user to fill in all the fields at once.




 
 After you have selected your form, a new form is created on your form, and the selected template is selected.




Editing an Existing Form





 
 To make edits to a template, first you need to open it in the Templates window.




 
 From the Templates tab, select the template you want to work with, and select “Open” from the Actions menu.




 
 This will open the form in the “Edit” tab, which gives you the ability to make edits to the form.




 
 Note: When you first open a template in the Edit mode, you will see a warning that the name of the template has changed. However, after you save your edits, the warning disappears. This is to prevent the user from accidentally saving a new template with the same name as one that was in use on the site.




Adding New Fields





 
 To add new fields to an existing form, first select “New” from the Template Actions menu, and choose the type of field you want (“Textbox”, “Textarea”, “Checkbox”, “Dropdown”, “Radio”, or “Hidden”).




 
 For more detailed information on each type of field, see the Field types.




 
 The new field will then be added to the form.




 
 Note: If you wanted to add a new field to a pre-formatted template, first you would need to uncheck the “Use a pre-formatted template” option.




Editing an Existing Field





 
 To make edits to a template, first you need to open it in the Templates window.




 
 From the Templates tab, select the template you want to work with, and select








Create a Data Validation Rule




“I am having this CSV file like below which contains 3 columns and about 40 rows with different data.



Column1 Column2 Column3



A x 2



B y 6



C z 8







I want to create a data validation rule to accept only data with values in a range like “Min Value = 2” and “Max Value = 20”.



So, I want to create a Data Validation Rule in Microsoft Excel like this:



Col 1 : “Min Value = 2”



Col 2 : “Max Value = 20”







How can I create such a Data Validation Rule?”







You can do it using Conditional formatting:




 
 Data Validation:



=AND(Data_Col1>=2,Data_Col1<=20)








 
 Conditional formatting:



Format Cells with =OR(data_col1>=2,data_col1<=20)







I would use another solution.




 
 If you copy your raw data (A3:A45) to Excel, and you have enough cells in the copied area, you may create a table, with header and a range of column and row for example:




 
 Then use an array formula to copy this formula in column B, using Paste Special > values only and then drag this formula down.



Now, if you use conditional formatting, you would have cells formatted like this:




 
 If the number of lines in your CSV file is less, you may use more rows in your conditional formatting formula.




 
 If you create a table with columns representing a minimum and maximum value of column A and rows representing the line numbers of your CSV file, you can paste the results of this formula in the cells and have a final sheet with a very nice formatting:




 
 You can also format the header and the range of columns and rows with a style of your choice.



Create your CSV file in the range of A1:A40




 
 In column B of your sheet paste this formula




 
 =AND(Data_Col1>=2,Data_Col1<=20) and drag this formula from column B to the rest of the cells that you want to copy to the CSV.
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Tables





Format a Cell Range as a Table




You can do this using the Text to Table feature of Excel.




 
 Select the entire range in question




 
 Click Text to Table on the Home tab



Using the data validation approach:




 
 In Excel, open the table and the table you are copying




 
 Click the Home tab, click Data




 
 Choose From Table and select the Table you want to use as your source




 
 Click the down arrow button to show your options.




 
 From the table menu select Validation > Data Type




 
 Click OK




 
 Now you can add your table style formatting and click the data validation to apply it.



You can also do it by using the following steps.




 
 Select the entire cell range.




 
 Select Data > Data Tools > Data Analysis.




 
 Choose the Format Cells button.




 
 Click Column Width.



Note: It is the same as the steps you have mentioned. However, you do not need to select the data range from the beginning.








Sort Data




“I have a list of names from the year 2020 that are in excel with a year 2020 column and a column for gender. In a new column I want to sum the numbers in the gender column based on the year in the year 2020 column.



I thought it would be easy to do in Excel as it was very similar to a pivot table.



I tried to find some tutorials on this but I have not found one.



I was thinking of using the following formula:



=SUMIFS(S$2:S$25,D$2:D$25,”>”&I2,D$2:D$25,”<=”&I2) where I2 is 2020”







Use INDEX to return the value of 2020 and SUMPRODUCT to find the sum of column B where A is the row number and the criteria you are using.




 
 =SUMPRODUCT(--(I2:I25>2020),INDEX(B:B,MATCH(2020,A:A)




 
 The INDEX(B:B,MATCH(2020,A:A)) will look at each row of B for 2020.




 
 You need to use VLOOKUP() function to achieve the result.



The function is to look for the value you are looking for in the column and return the corresponding value in the same row.



The syntax is:




 
 =VLOOKUP(<value>;<table>;<range><range_direction>)




 
 For your problem:




 
 =SUMIFS(B2:B25;A2:A25;”>”&I2;B2:B25;<=I2)



I have added > and < signs for your test input. This is for making sure the first range is >= 2000 to get the result from the last year you want.








Filter Data




Microsoft Excel Filtering is one of the most used data analysis technique in a large number of data analysis activities. For the data analysis in Excel the filtering is the best data mining and analysis tool which gives a lot of options for data analysis. The filter is the most useful tool in the Excel which gives a great control over data sets. The Excel can filter a range of records in the data. The Excel give a lot of options for filtering the records based on data type, value, date, text, etc. Microsoft excel helps the user to do data mining by filtering the data sets in the different ways in a huge way. By filtering a user can see the record according to the data type, value, date, text, etc. for record the user can change the filters for record and see the filtered result in the data worksheet.



Filter Excel records in different ways. Filter Excel Records with data type:



There are different type of data sets present in the Excel. With the help of the Excel user can see the record according to the data type. The user can modify the filter according to the data type so that he can see the filter record by type. For example, if a user has the date and time and time zone fields in the records the user can filter the data based on the date or time. For example, for a record the user can filter according to date and time in the range based on year, month, day, time, etc. For example, a user can filter the data based on date.








Filter Excel Records with date




The date in Excel is very useful to filter the data. For example, if a user has the date as 01/01/2013 then he can filter the records with this date in the data set. For example, the user can select the date in the date field as a range. For example, if a user have a date range then he can filter the record based on the date range. By modifying the date range filter in the range the user can see the record accordingly.








Filter Excel Records with time




Time in Excel is very useful for data analysis as well. If the user has the time in Excel then he can filter the records according to the time. For example, for the data set the user can filter the record with the time. For example, the user can filter the record by selecting the time field in the time range. For example, if a user have the time range then he can filter the record accordingly.








Filter Excel Records with time zone




Time zone in Excel is very useful for data analysis as well. For example, if the user has the time zone in Excel then he can filter the records according to the time zone. For example, for the data set the user can filter the records according to the time zone. For example, the user can filter the record based on the time zone by selecting the time zone. For example, if a user have the time zone then he can filter the record accordingly.








Filter Excel Records with date and time




Date and time in Excel are very useful for data analysis as well. For example, if the user has the date and time in Excel then he can filter the records based on the date and time. For example, the user can filter the records by selecting the date and time range. For example, if a user have a date and time range then he can filter the record accordingly.








Filter Excel Records with date and time and time zone




Date and time in Excel are very useful for data analysis as well. For example, if the user has the date and time in Excel then he can filter the records based on the date and time. For example, the user can filter the records based on the date and time range. For example, if a user has a date and time range then he can filter the record accordingly.












Filter Excel Records with date, time, and time zone and time period




Date, time, time zone and time period in Excel are very useful for data analysis as well. For example, if the user has the date, time, time zone and time period in Excel then he can filter the records based on the date, time, time zone and time period. For example, the user can filter the records based on the date, time, time zone and time period range.
















Add Table Rows or Columns




First, you need to have 3 sheets in your workbook; the data, the header, and the footer. The header and footer sheets are used to align the data sheets and the data sheets are used to store the data.



The header sheet is just a single row with the title of the workbook in column A, the first blank row is column B and the next blank row is column C.



The footer sheet is exactly the same, but for the column B.



The data sheets should be as simple as 3 to 5 rows; each row should be a row in your original data with column A being the title of that data.



Finally, you need to hide the sheet tabs, then insert a chart. The chart needs to be moved to the right side (if in a fixed position) and with its size to fit the data.








Remove Duplicate Values




It will be simpler if you create a new column (P) to hold the product info.



This is the code that you can use in P2 to find duplicates and delete them



=INDEX($A$2:$A$1000, MATCH($B2,$B$2:$B$1000,0),MATCH($B2,$M$2:$M$1000,0))



You can drag the formula down the column to P2 and you are done!



To find the duplicate in the source data sheet, you need to create a unique index across columns A and B, and then filter that range. You will be able to see the duplicates by adding one more filter:



=INDEX($A$2:$A$1000, MATCH($B2,$B$2:$B$1000,0),MATCH($B2,$M$2:$M$1000,0))



This will be in column P2.




 
 So, this will work in P2



=INDEX($A$2:$A$1000, MATCH($B2,$B$2:$B$1000,0),MATCH($B2,$M$2:$M$1000,0))



For all the prices in the range you would drag it down and fill.



If you want to delete the duplicate, you will first filter based on row numbers. This will give you the index of the rows with the duplicates. Then you can use INDEX and ROW in combination to delete the duplicate.








Insert a Slicer




A slicer can’t be placed in a sheet, it has to be in the worksheet where it appears. However, you can use a worksheet function to create a slicer for a range of cells.



Slicers created using VBA are static, you can create them in Sheet1 or any other sheet.



To create a slicer for Sheet1 cells A1:A7 use this VBA code. Please be aware that I am using the ‘Slicer’ button in VBA editor, not the ‘Insert Slicer’ button, so it will have a different name.



Sub CreateSlicer



 Dim sSlicerName As String



 Dim sRow As Integer



With Sheet1:




 
 SlicerName = .Slicer(.Cells(1, 1), .Cells(.Rows.Count, 1).End(xlUp)).Name




 
 For sRow = 1 To .Cells(.Rows.Count, 1).End(xlUp).Row




 
 Slicer(.Cells(sRow, 1), .Cells(sRow, 1).End(xlUp)). _



Action = xlSlicersActionCustom




 
 .Slicer(.Cells(sRow, 1), .Cells(sRow, 1).End(xlUp)). _



SlicerType = xlSlicerFixe




 
 .Slicer(.Cells(sRow, 1), .Cells(sRow, 1).End(xlUp)). _



 Visible = False




 
  ‘Add slicer to the first sheet’s range and make it visible



 With ThisWorkbook.Worksheets(1).Range



 Set sSlicer = .OLEObjects.Add(ClassType:=”Forms.Slicer.Slicer”)



 sSlicer.Left = Cells(1, 1).Left



 sSlicer.Top = Cells(1, 1).Top



 sSlicer.Height = .Height



 sSlicer.Width = .Width



 sSlicer.ZOrder msoBelow



 .OLEObjects(1).Object.Caption = sSlicerName



 .OLEObjects(1).Object.Visible = True



‘The next macro gets called by an Application_Startup event in the main application code



Private Sub Workbook_SheetActivate(ByVal Sh As Object)



 Dim wbThis As Workbook



 Dim WS As Worksheet







 Set wbThis = ThisWorkbook



 Set WS = wbThis.Sheets(”Sheet1”)



 If WS Is Nothing Then Exit Sub







 If (Application.Version > 10.4) Then



 On Error GoTo EndMacro



 End If







 ‘Make your slicer visible



 ThisWorkbook.Worksheets(1).Shapes(sSlicerName).Visible = True







 ‘This next chunk is an error handler because the code above should always work.



 On Error GoTo EndMacro



 MsgBox “The macro has stopped working. Please report this as a bug.”



 Exit Sub








Table Style Options




“I have the task of putting together a template for some of my colleagues that they can use to print reports from. The reports will have tables in them that have a couple of headers and a couple of columns. The table has a header row, and a total row at the bottom.



I figured that I would save the excel workbook as a template and then just download the individual files for the people using the template to be emailed out.



What I was wondering is, can you customize a table style in Excel such that the first table you define gets put into the template for all new tables to be printed from?”




 
 When you create a new table, right click on the cell that contains the data and click cell formatting > table style




 
 Click the tab for the table style you want




 
 Drag the style across to the other cells that will also be in the table



Example



If the table style was saved in a specific worksheet, you could right click on the first cell in the table and click Format As Table or Format Painter and then right click on the formatting cells and then choose Table Style from the menu




 
 You can also just change the formatting options in the Cell Formatting dialog (Tools > Options > cell formatting)




 
 If you just want to change the text you can use Cell Style Formatting or just find the text in the cell and copy and paste it into a new table, right click on the first cell and select Paste Special



You may choose the first table style you created as default one for a new table.




 
 Open Excel’s Options > Advanced Options and there, select the first table style you created for new table cells:



Alternatively, you may change the default table style for new cells.




 
 Open Excel’s Options > Advanced Options and there, select the table styles to be applied to new cells in the Table Style tab:



By the way, I guess you are not clear enough about what a style is.



Styles are applied for objects: rows, columns, text boxes, cells, worksheets, etc.




 
 To add a style to an object, just click the object (any where in your worksheet), and select the Add button in the Formatting toolbar:



Here is the example:



You may not select all objects before you add the style. For instance, you may want to add the style only to a cell, a column or a row, etc.




 
 In that case, you should not select all objects before you add the style. Simply select one object and click the Add button.




 
 In the dialog window that opens up, you may select a specific style or click the Add button.




 
 To delete a style, select the object you wish to delete, and then select the Delete button.














CHAPTER FIFTEEN





Intermediate Formatting




“I have a list of data in my excel workbook which is not in columns, but rather is in rows. I want to do intermediate formatting, with no borders. If I select all of the data I want to format, I can right click on the column headings and choose “Intermediate format”. But how do I do this if the data is in rows, rather than columns.”








 
 Select the cells in the range that you want to format and do the following:




 
 File->Options->ApplyToSelection



It will automatically apply the formatting to the selected cells and you’ll be able to use the borders.



“I’m no expert on Excel but I believe you’ll have to format them separately as in normal Excel, rather than being in rows.”




 
 If you have access to other formats, you could use that if you wanted to.




 
 Edit: It looks like that’s just how you do it in Excel, if you only want to select the data.



For formatting each cell individually, you can use:




 
 File | Options | Apply To




 
 Select the whole column




 
 Click on Apply button



If you select individual cells then this option will be grayed.








Apply Conditional Formatting




To make a column that gives the “Total” for the sum of the previous 7 columns for the “Total” column.




 
 Use the following formula in Cell E4:



=IF(A4=A3,SUM(A4:A3),”)



If you want to calculate the total for only the first seven cells in column A:



=IF(A4=A3,SUM(A4:A3),0)



I’m assuming you are trying to sum values in A up to the last 7 and for any value beyond 7 to have a 0 value.



Then:



=SUM(INDEX(A:A, MATCH(MAX(A$3:A$1000), A:A, 0)+7):INDEX(A:A, MATCH(MAX(A$3:A$1000), A:A, 0)



MATCH(MAX(A$3:A$1000), A:A, 0)



will find the greatest value in column A, where the max goes through the entire column A



+7 is the value from MAX() that the index will go out from.







MATCH(MAX(A$3:A$1000), A:A, 0)




 
 finds the position where the max occurs.




 
 Then we just add on 7 to get the offset from the max and then the entire row where the max occurs.








Apply Cell Styles




If you already have an excel file, you know how hard it is to apply Cell styles. In general, there are a lot of different ways to set a cell, it is not like in Word where you can always use a template. Herein, we will solve that problem in a way may’ve never thought of.



In this tutorial, I will show you some tricks and how you can quickly apply a cell style in a way you’ve never thought of.



I guess you already applied Cell Styles and it has become a part of your Microsoft excel workflow. But have you ever thought of using the Cell Styles functionality to do other useful things? I guess your answer was no.



Herein, we will explore how you can use the Cell Styles to do useful things.



Let’s begin!




 
 Create a simple excel file




 
 Select the entire spreadsheet.




 
 Press Alt+A to get the Home tab.




 
 Now, open the Add-Ins tab and scroll down to find the Styles group. By default, MS Excel will open the Cell Styles window.



In order to apply some changes in this window, first let’s delete a few styles.



As you can see, I already have a few styles applied to the selected cell. These styles have a yellow background color. You can select any style to delete and you can see that the background color will change to a darker color. It is similar to what you have seen in Word, but not exactly.







So let’s click on the yellow color background to remove that color.



You can also see some colors appear at the bottom of the Cell Styles window. These colors can be used to change the styles.




 
 Just select the cells in the spreadsheet, one at a time, to change the style of all the cells.







Now, let’s create some styles for this sheet.




 
 After applying a few styles, there is a red “X” symbol on the sheet. Click on this symbol to close the window.




 
 Now that we have removed the styles, the cell background color is white.




 
 In order to get the yellow color back on the spreadsheet, we need to enable the Yellow color. Click on the “Yellow color” option in the Cell Styles window.




 
 Now when we click on a cell, the cell background color will be yellow.




 
 But if we have selected a few cells, we will have a yellow background only for those selected cells. This is similar to what you have seen in Word.



So let’s create a few styles to select a range of cells, or you can say, a block of cells.




 
 For this example, I will select from the first row (A1) to the fifth row (E5).




 
 Just click on the “Block” option, to select all the cells between the first row (A1) and the last row (E5).








Apply a Workbook Theme




Let us say that you have a spreadsheet in your workbook that you want to look a different. So you create a new file. It’s a new workbook and you don’t want to change the title of the workbook. So what you want to do is select your current workbook. Open the Theme and click on the button and select your theme that you want. So the new workbook now has the same color scheme that your current workbook has. There are a lot of options. This is just a basic theme. You can change the colors, you can choose different fonts, you can choose different shapes.



Let’s say that you want a theme that is already made for you. Or you want to create your own. So I am going to create a workbook using PowerPoint. Click on the PowerPoint button. Select the Presentation option. I have already created a workbook that I am going to use. I want to copy it. So you just right click on the workbook that you want to use. The file, go to copy.



Once the file is on your desktop, you open it and you will see that all the formatting is similar to the theme. So what I am going to do is I am going to close the file and create a new file and once you create a new file, go to Excel. Click on the button. Now the theme has changed. So what you need to do is you can change any of the formatting on this workbook that you are using in Excel. So I am going to go to Theme.



Let me change the Background color and the font.



Let me change the Shape. I want to change the Fill color to be the same as the background color. So what I want to do is go to shape. Click on the Fill. And you see the fill color is black. So I can choose what I want to use as a background color and I want to use a particular color.



So for this one, let me choose orange. Now, once you have your theme, you don’t have to worry about what file is using what theme. You just go to apply a theme. Click on the apply button. And your entire workbook is going to change to whatever theme you choose. So if you are having a theme that you are not happy with, all you need to do is click on the workbook.
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Collaborate with Excel




How to:




 
 Use one line of code to add a cell below the header if the row contains a cell with a specific number of characters (including blanks).




 
 Use one line of code to add a cell above the header if the row contains a cell with a specific number of characters (including blanks).




 
 Use one line of code to add a cell to the left of the header if the row contains a cell with a specific number of characters (including blanks).




 
 Use one line of code to add a cell to the right of the header if the row contains a cell with a specific number of characters (including blanks).




 
 Use one line of code to move a cell to the end of a row (or to the beginning of a row) if the row contains a cell with a specific number of characters (including blanks).




 
 Use one line of code to move a cell to the beginning of a row (or to the end of a row) if the row contains a cell with a specific number of characters (including blanks).




 
 Use one line of code to delete a cell that doesn’t contain any data from the current row if the row contains a cell with a specific number of characters (including blanks).




 
 Use one line of code to delete a row that contains a specific number of blanks if the row contains a cell with a specific number of characters (including blanks).




 
 Use one line of code to create a conditional (numeric) formula that returns a result according to the current cell in the row to which the function is applied.




 
 How to calculate the number of items in the column: count the number of rows in a specific column and add the column header from the bottom up (or top down)




 
 How to calculate the number of rows: 1 for the column headings, 2 for the row headers. If row headers in the beginning of the table, then the header length is included in the count of 1




 
 How to create a formula with the current date in a date column and an increment for the month? (if the date doesn’t exist)




 
 Use one line of code to insert a formula in a cell, where the formula is calculated with the current date in the current row in a date column. If the date doesn’t exist, then the default value in the current row is used.




 
 Use one line of code to insert a formula in a cell, where the formula is calculated with the current month in the current year. If the month doesn’t exist, then the current month in the current year is used.




 
 Use one line of code to convert date value to string representation (if the date doesn’t exist)







How to remove (in rows and columns) all cells with data below a value?



For rows, use the following formula:



=TRUE()



For columns, use:



=NOT(ISBLANK())



(if you want to remove all columns without values.)







How to remove duplicates from a date/time/number/string value?



I think the best way to do all of this (if you want to go the VBA route) is to use a helper table:



In Cell A1:



=VLOOKUP(A1,$C$1:$I$1000,2). That’s a helper table. The column 1 in the lookup list corresponds to the header in your original table, so if you have a header at cell A1, the lookup will return an x value.








Add a Cell Comment




Add a cell comment for a particular cell. The user can also make a comment of type ‘Note’, in this case, no date will be available to the user. The cell comment needs to be added from the spreadsheet itself, not the user.




 
 Open the spreadsheet.




 
 Select the cell of the comment you want to add, you can add multiple comments




 
 The ‘Add comment’ dialog opens.




 
 A number of option menus are available, as shown in the figure.




 
 Select ‘Note’ and the user can make a comment for the cell. In this case, the user can make a comment for the cell if they want. There are options to set the cell comment in the ‘Note’ format.



The user can select the date to get the comment in the ‘Note’ format. The comment for the cell will be ‘Note on: ‘. If the ‘Date’ is not set for the ‘Note’, then the date for which this note is created is set. The user can also select if the date of the note is to be the cell’s cell’s current date or to be the previous day. In this case, the cell’s date will not be available to the user for editing.








Invite People to Collaborate




In Microsoft Office, there are multiple means to communicate with users, and one such way is to use Invite people to collaborate. With this feature you can invite more than one user to work with you on one specific document in your Office library, either on the web or on a computer. It is often used to ask other people to help you complete a project or to provide their feedback and to comment on certain points in your project. Invite people to collaborate will be especially useful if you have an account on a SharePoint online site, since that site allows you to share documents and access your online Office library with others.



In order to use the Invite people to collaborate, you must be a site admin. Before you can proceed with the demonstration, you need to know:




 
 Your site’s url (hosted by Office 365).




 
 The credentials of the user you want to invite. You must login in the SharePoint admin center as the user you want to invite.




 
 The Office 365 Hosted SharePoint online site url.



This feature can be used to invite as many as 100 people to work with you on a specific document.



Step 1 – Create a New Office 365 SharePoint online Site



In this step we will create a new Office 365 SharePoint online site. This will be the site where we will be collaborating on the document. For this example we will call the site mycollaboration.




 
 Go to the Office 365 SharePoint admin center and click on Sites. In the Search textbox, enter “mysite”. Click on “Create a Site”, and enter a name for your site. In this case, we will enter mycollaboration. In the Site URL field enter “https://hostedspace.sharepoint.com/sites/mysite/“. For site permissions, choose “Full Control“. Click on Create site. You can download the site configuration from your Office 365 SharePoint admin center as an .xml file.




 
 Click on the Save button to save the changes to your site.







Step 2 – Create a New Document



Now you need to create a new document. In this demo, we will create a document with the title, “Word document #1”.




 
 Go to the Office 365 SharePoint admin center and click on Documents. In the Search textbox, enter “mysite”. Click on “New document”, enter a title for your document, and click on “Create”.







Step 3 – Receive and Accept the Document



To collaborate on the document, now you must invite the document to the site.




 
 Go back to the Office 365 SharePoint admin center and click on Documents. In the Search textbox, enter “mysite”. Click on “Receive document” and choose the people you want to collaborate on the document. In this case, we will only allow John to see the document. Click on Receive. John must approve of the changes before they will appear. If he accepts the changes, he can now begin editing the document.



That’s it. John can now access the document he is editing and make changes to the document. When John is done with the document, he must send the document back to your site. Go back to the Office 365 SharePoint admin center and click on Documents. In the Search textbox, enter “mysite”. Click on “Send document” and choose the document you want to send. Click on Send.







Step 4 – Accept the Changes and Save the Document



After John has changed the document, he can now accept his changes.




 
 Go back to the Office 365 SharePoint admin center and click on Documents. In the Search textbox, enter “mysite”. Click on “Accept changes” and choose the changes you want to accept. Click on “Ok”.



You must save any changes before they are viewable by others. Go back to the Office 365 SharePoint admin center and click on Documents. In the Search textbox, enter “mysite”.








Co-author Workbooks




Before begin;




 
 You’ll need to have a copy of Word 2019 and Word 2021 installed to do this.




 
 If you are on a Macintosh you will need to have ‘MacXOffice’ (a program similar to Word but much cheaper) installed. (see http://macxoffice.com/ for info)




 
 The ‘MasterWorkbook’ and the 2 ‘WorkbookAuthoring Workbooks’ contain all the information. Each workbook contains a ‘MasterWorkbook’.




 
 The WorkbookAuthoring Workbooks contain all the information on how to co-author the MasterWorkbook and one other workbook.



To begin, open up all 3 workbooks and find out which book you would like to work on by reading the instructions on how to do that. Then download and open up ‘WorkbookAuthoring Workbook 1’.




 
 You need to know two pieces of information that you are sent to an email when you complete this workbook. Your name and email address.




 
 You will get this information once you are registered. To register just click on ‘Registration link’ and follow the instructions.




 
 From here you will have to log in to the site using the email address and password you used when registering and you will be sent the co-author workbook instructions.




 
 The workbook opens up in a new tab.




 
 You will be sent an email telling you the time to expect the emails containing the instructions.




 
 When you receive the instruction email, copy the instructions and put them in your word document as an Excel table.




 
 You will have to do this because the ‘Instructions’ will look like they have no formatting.




 
 Do the first page of instructions, or the first two pages of instructions.








Protect a Worksheet




A sheet can be protected in Excel or you can lock a sheet. If you want to keep the sheet from being changed (if that is what you want), then you lock it. When you do that, you can still add or delete from a protected sheet, but the changes will not be saved. If you want to be able to make changes, but not to allow people to look over your shoulder while you do, then Excel creates a sheet with special security features. This is a great way to protect your sensitive data and keep it from getting out.








Add a Workbook Password




In a normal way you can not add password for a workbook in Microsoft excel. There are two types of password for a workbook in excel, one is a global or master password and the other is a local password.



Master Password



The master password is a combination of two pieces of data. These are the two pieces of data which are entered while creating a workbook. This password has nothing to do with the local password for this workbook. If the local password is not same as the master password, it would not allow the workbook to open.



We should be careful while storing the master password. Some people store it as a text file and there are many ways to crack the master password.




 
 While adding the local password, in the new screen.




 
 Click on the tab named “Workbook Password”. Then give the text box which is in the below image, enter the master password,




 
 In the text box, click on the button named “Set Password”.



Now it’s ready. If the master password is entered in the textbox, then the workbook opens otherwise the message “The Workbook Password cannot be set”. If the workbook opens with the master password, then the workbook password must be changed.



Local Password



It is easy to add a local password for the workbook. To add a local password, in the workbook menu bar, click on the tab named “Workbook Password”. Then click on the “Add” button. The screen will appear and the data which you have entered as a password will appear. You need to enter the same password for the same local password as given in the tab for this local password. Then click on the OK button. If you need to change the local password, you can open the workbook menu and click on the tab named “Workbook Password”. Then click on the “Edit” button. After clicking on the “Edit” button, the textbox appears. There you need to enter the old password and give the reason for changing the password.
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Pivot Table Elements








PIVOTTABLE elements are used to create a data table in excel which can be used for data manipulation.




What are Pivot table Elements?




A pivot table is a compact way to show the results of any data analysis, whether you performed the analysis yourself or you have imported the data from another file. A pivot table can summarize the results of any analysis of the data set and use any field as a parameter for the analysis.






[image: ]




Create a PivotTable




To start a PivotTable, do the following:




 
 Select the cell with the data to analyze.




 
 From the Data tab, in the Sort & Filter group, click PivotTable.




 
 In the PivotTable Fields list, click New.




 
 In the Filter list, select the items you want to group together.




 
 In the values list, select a name for the field, such as Sum of Units.




 
 Select the type of aggregation, such as Average, from the drop-down list.




 
 Click Add, and repeat Steps 5 and 6 to add more fields.



To create a PivotTable from a table in a worksheet, follow these steps:




 
 Click the down arrow next to the Name box, and select Table.




 
 In the dialog box, choose the source data.




 
 On the PivotTable Tools tab, in the PivotTable group, click New PivotTable.




 
 On the PivotTable Tools Design tab, in the Category group, click Insert PivotTable.




 
 In the Insert dialog box, select the Table option.




 
 In the PivotTable Fields list, in the Columns area, select the desired field.




 
 In the Values area, in the Fields list, select the desired calculation.




 
 Click OK.



Alternatively, you could import the table directly, which will create a new table in the Data Model. From this Data Model, you can add the rest of the functionality that you require.



If you want to group by different fields use sum and/or count. Also, you can remove the other fields from the query. Then, to add the other fields to the pivot table (including total), click the “Fields” option under the “PivotTable Options” tab. To remove the first pivot table, right click and delete the pivot table.








Add Multiple PivotTable Fields




You might have multiple pivot tables and several pivot fields defined in a single sheet. When we have multiple pivot fields defined in a single sheet, it is very useful to have the below steps in one macro.



Note: Steps 1-3 are used to add multiple pivot tables on the same sheet using the PivotTable Fields option, which is also known as pivot tables created using the fields option. The macro will work when there are 2-20 pivot tables. You will not be able to add multiple pivot tables using steps 1-3 when there are more than 20 pivot tables in the sheet. In that case, you will need to use a different macro.



Step 1: Create a new module in Excel and write the following code:



Sub AddPivotTables()



‘//



‘ // This macro works for multiple pivot tables on a single sheet



‘//



‘ // You will need to use a different macro when there are more than 20 pivot tables in the sheet



‘//



‘ // This macro will add multiple pivot tables on the same sheet



‘ //



‘ // This macro is used in the following steps. Step 1 - step 3 are used to add multiple pivot tables on the same sheet



‘//



‘ // We need to define a variable to keep track of what table should be added and we need to keep adding pivots tables to the sheet



Dim PivotTable As String



Dim i As Long



‘// If there are more than 20 pivot tables, you will not be able to use this macro



‘// In that case, you need to use a different macro.



For i = 1 To Worksheets.Count



If Worksheets(i).Name = “Table” Then



PivotTable = “PivotTable” & Worksheets(i).Name & “!R2C1”



Worksheets(i).PivotTables.Add(PivotTable, “PivotTableFields”)



End If



Next



‘// Now, create multiple pivot tables using the pivots created in above step:



‘// This loop creates multiple pivot tables on the same sheet



For i = 1 To Worksheets.Count



If Worksheets(i).Name = “Table” Then



Worksheets(i).PivotTables.Add(PivotTable, “PivotTableFields”)



End If



Next



End Sub








Group PivotTable Values




“How do I group values from a PivotTable based on their name in another field”?




 
 Use the Filter option and select Values.




 
 After filtering the Pivot table, add a column with the name of the filter and right-click the selected columns, choose Sum and the Sum of the filter, will be added as a new column.



UPDATE: After writing the above, I realized that the filter option will work only if there is a numerical range. So, instead of using the Filter option, use this option, which will allow you to sum multiple values.




 
 To sum all values that match the first filter, right click the pivot table and choose the values option. To sum all the values between two values, right click the pivot table and choose the cells option.




 
 You can then add a new column and use the Sum function in it.



UPDATE 2: To sum only values that match the first filter, you can either right click the pivot table and select values option or select the filter tool (the one used by adding a new column) and click the filter again. Then, as said above, add a new column and sum.



UPDATE 3: You can try something like this:




 
 Select all values you want to sum and duplicate it by using Ctrl+J or selecting Format -> Cells -> Paste special -> Paste Values.




 
 Sum all values in the new column and add the field that contains the values you want to sum.




 
 Now you should have a new column with only the values you want to sum.



UPDATE 4: As you can see in the screenshot above, you can use the option filter and cells to sum only the values you want to sum.




 
 You can select all cells in the new column (Ctrl+A) and click Filter -> Cells to sum all the values. Or, to sum only the values that you want, you can use the filter option.








Refresh a PivotTable




“One problem I have seen before is if the PivotTable was updated, refreshing the pivot will not work.



For example,



We are using a Pivot Table to do some business calculations on our excel project.



At time t=1,



Our daily revenue is x dollars,



We have a budget y dollars,



The result was x-y dollars should be loaded in the PivotTable daily for us to calculate the daily profit.



Now, our daily revenue is x+y dollars, the result will be x+y-y=x dollars.”







It sounds like you are talking about a PivotTable chart. When you updated your data in your data table, Excel recalculated the PivotTable. This may have happened every time you made a change to the data table, which is probably what the OP meant by “refreshing the pivot”. When you refresh a PivotTable, it rereads your pivot table to refresh the numbers, but does not recalculate the PivotTable.



To refresh a PivotTable and recalculate the PivotTable:




 
 Select the PivotTable in the PivotTable tab of the Data ribbon.




 
 Right-click the PivotTable and choose Refresh.




 
 You can also use the CTRL+SHIFT+R shortcut.



In addition, You could have two options to solve this:



1) Click anywhere in the pivot table and then press Ctrl+F5. This will refresh the pivot table with new data



2) Go to File->Options and change the option “Refresh PivotCache” from [Always] to [Selected Only]




 
 Select the PivotTable in the PivotTable tab of the Data ribbon.




 
 Right-click the PivotTable and choose Refresh. This will recalculate the PivotTable.



To refresh a PivotTable and recalculate the PivotTable:




 
 Select the PivotTable in the PivotTable tab of the Data ribbon.




 
 Right-click the PivotTable and choose Refresh.




 
 As others have pointed out this is the “shortcut” key combination you want to use.








Format a PivotTable




Steps to format a Pivot table.



Step 1



First we will just open the spreadsheet that we had created before.



Step 2



After opening the spreadsheet, click on the pivot table icon.



Step 3



A Pivot table opens up in the excel sheet.



Step 4



After clicking on the pivot table icon the pivot table will show on the right hand side.



Step 5



Now, let’s drag the sales rep offices name from the sales rep section in the data tab to the row label section and make the selection of drop down from the drop-down menu and set the name of the sales rep office like this.



Now, select the customer name from the data tab and drag and drop it in the row label section and make the selection of drop down from the drop-down menu and set the name of the customer like this.



Step 6



Next, let’s add sales rep office name to the column label section of the pivot table.



Step 7



Next, let’s add the amount of customer spent to the data section.



Step 8



Next, let’s add the amount of cash received to the data section.



Step 9



In the grand total section, let’s add sales rep office name and customer name to it and put the percentage in the total.



Step 10



In the grand total section, click on the grand total icon to add a sum formula.



Step 11



In the sum formula put the formula like this;



=COUNTIF([Sales Rep Offices]!I2,[Sales Rep Offices]!E2)



Step 12



Click on the grand total icon.



Step 13



After clicking on the grand total icon a sum formula will show up in the Grand total section.



Step 14



Let’s add the amount spent to the data section in the grand total section.



Step 15



Click on the grand total icon.



Step 16



Add the sum formula to the grand total section like this;



=SUM([Cash Receipts])



Step 17



In the grand total section, click on the field icon to change it to table value and select the customer table.



Step 18



Here we see that the total sales rep office amount and total cash amount of all the transactions are shown.



Now we are going to add another report by using the same sales data and pivot table. This time we will add another pivot table, sales rep office name, and customer name for this:




 
 First, we have to create another pivot table.




 
 Click on the pivot table icon.




 
 First let’s add customer name to the column label section.




 
 Let’s add the customer type to the column label section.




 
 Let’s add the amount to the data section.




 
 Let’s add the rep office name to the pivot table and select the column label.




 
 Let’s add the amount to the pivot table and select the column label.




 
 Finally, let’s add the total sales rep office amount to the grand total section.




 
 Let’s close the pivot table and add the sales rep office name.



Now we have to add another report by using the same sales data and pivot table. The only difference is that this report will show customer name and rep office name.




 
 Click on the pivot table icon.




 
 First, we have to add the rep office name to the column label.




 
 Next, we have to add the customer’s name and type.




 
 Let’s add the amount to the data section.




 
 Now we have to add the grand total amount.



Finally, we have to add the rep office name.



Now we have to add the rep office name to the second pivot table. The only difference is that this report will show customer name, type and amount.



Step 1



Click on the pivot table icon.



Step 2



Let’s add the customer’s name to the column label.



Step 3



Let’s add the customer type to the column label.



Step 4



Let’s add the amount to the data section.



Step 5



Now we have to add the grand total amount.



Step 6



Finally, let’s add the rep office name. Now let’s add the rep office name to the second pivot table.



You need to add a PivotTable to the Excel Workbook; You need a table that you have to use as the source for the PivotChart.



To begin:



Open an Excel workbook



Right click on the workbook and select: Insert -> PivotTable



Give the table the name of: Pivot Table1



Insert a blank row at the bottom of your table and select: Insert -> PivotTable Fields



Give the row the Name of: Row 1



Select the column: Date



Right click on the Date column



Select the Format option



Under Number select Date



Set Formatting to General



Select the column: Sum



Right click on the Sum column



Select the Format option



Under Number select General



Set Formatting to 0.0



Select the other columns:



Set the same formatting as in step 8.



Right click on the Row 1 and select: Insert -> PivotTable Fields



Give the Row 1 the Name of: SUM



Select the SUM



Set the formula: [SUM]



Give the SUM Field the Name: SUM



Select the Row 1



Set the Row field to: SUM



Right click on the SUM column



Select the Format option



Under Number select General



Set Formatting to 0.0



Under Summary select Average



Set Formatting to 0.0



The result:



When you add a new row to the query the pivot table will not update. You need to update it using the menu item PivotTable1



Note: In order to view the pivot table you need to right click on the workbook > View > Select Pivot Table














CHAPTER EIGHTEEN





 
Pivot Chart




Pivot Chart, is a popular charting tool that is used to display data in a variety of different formats. Pivot chart is easy to use in Microsoft excel, you can create basic and advanced charts. Microsoft excel has a default set of Chart tools, but in order to get the best out of Pivot chart, you need to learn the Pivot tool itself.



In this chapter, I will take you through the basics of how to create a pivot chart on excel, and what to keep in mind before you create it.








Create a PivotChart




In order to create Pivot chart on excel, you need to have following things:




 
 Know the basics of excel




 
 Know the basics of charts in excel







Step 1: Create a new Excel file




 
 Open the excel application




 
 Create a new blank workbook. If you don’t have a blank workbook, you can open it as a template.




 
 When you open the template, create a new sheet and name it “Pivot Chart”.







Step 2: Import data in the Excel file




 
 Insert a Data table in the first sheet.




 
 Click on “Insert”




 
 Select “Tabular model” and click ok.




 
 Then right click on the Data table




 
 Select “Data View” option. It will display the data. You should see 2 columns in the first sheet called “ID” and “TOTAL”.




 
 Click on the second column and drag the field so you can see the data




 
 Then press “Tab” to enter edit mode, then change the field’s name to “Name”.




 
 You should see the data now as: Name Total







Step 3: Pivot data in excel




 
 Go to the first sheet




 
 Click on the pivot button on the right top corner of the screen. A Pivot chart should be displayed on the window.



You can see the pivot chart has 3 pie chart, but you will learn more about that later. For now, let’s focus on basic features of a Pivot chart.




 
 Select your field/column that you want to pivot on




 
 Now click on the button next to “Show Values”




 
 The pivot tool now show you how many rows have the selected field has




 
 Click “Sum of” and it will display the total of the field for you.







Step 4: Add other columns



Now you can see the data has 3 columns, there are some fields that you might want to know. Click on the field that you want to change (eg: Income), there are 3 fields on it that you can choose, the other 2 are “Yearly Income” and “Number of Employees”.




 
 Select the field and drag it from the data table to a new area (eg: Total), once you done with that, press tab and the new field will display on your data table.




 
 Then drag “Number of Employees” to the next column and change the column title to “Number of Employees”.



Step 5: Hide / Unhide rows



Now you can either use the pivot chart or use the pivot table to understand the data. In this example, I chose to use pivot table.




 
 Click on the top row of the Pivot table to reveal hidden rows and click on the middle row to un-hide that row.




How to display the data in a matrix like structure




Matrix like structure can be displayed in an excel spreadsheet. If you want to see data in the matrix like chart, first you need to create two-dimensional matrix like structure and put data in the structure. After this you can use the matrix like chart to see the data in a matrix like chart. Data can be included in a matrix like chart, if you need to create a matrix like chart. If you want to show the data in a matrix like chart, you need to create a matrix like structure. If you need to include rows and columns in your data, you need to use 2d matrix like structure and data can be included in a matrix like structure. To create a matrix like chart, first you need to create a 2d matrix like structure and include data in the structure. To use matrix like chart, go to chart - chart wizard - pie.



To create a matrix like chart:




 
 Go to chart - chart wizard - pie. This can be useful if you want to display the data in a matrix like chart.



First, you need to create a 2d matrix like structure.




 
 Go to Data - Pivot Chart - Create.



To use the pivot chart, click on the pivot chart and choose data



Create chart. In the chart window, select chart type - pie.



To create a matrix like chart, you need to use two-dimensional matrix like structure. This chart type displays each section of the chart as an individual pie, but shows all of the sections of the pie chart at the same time.



Add data to matrix like chart:



Go to data - PivotChart - add data.



Select Data - matrix.



Click on the add button.



Select a data range and show the data in a matrix like chart:



To select a data range;




 
 Click on the data range selector in the upper left corner.




 
 Then click on the arrows next to data range and select your data range. You can select multiple ranges. You can see the data in a matrix like chart.




Modify PivotChart Data




In PivotChart Chart Type you can modify and view your data according to your need. In order to understand the concept we can consider following example.



How to get the PivotChart and how to access the PivotChart Data?



When you right click on the PivotChart and select “modify” tab the Chart Area of PivotChart will be visible. You will get three options to select;




 
 Edit Data




 
 Edit Ranges




 
 Edit Legend



In case of Chart Type we get only the Edit Data and Edit Ranges option. Let’s now consider below example:



We can say the Chart Type = PivotChart as we cannot see the Chart Data on PivotChart.




 
 First you can see the Chart Data area is not visible in this case.




 
 Now you can see the PivotChart chart area is empty. You can see the PivotChart in three different colors.




 
 Blue color is showing the Chart Type of the PivotChart.




 
 Yellow color is showing PivotChart




 
 Red color is showing the Pivot Table.




 
 Let’s change this chart Type to “PivotChart”.




 
 As you can see it is a pivot chart Type as shown in the below image.




 
 Now we can see the PivotChart data.




 
 Let’s modify this data by adding data for the next category “Tubing”.




 
 Similarly, let’s add data for the next category “Blades”.



Now we can see the PivotChart data. We can see the Legend in this case and that’s it. We can now see the PivotChart.




 
 If you don’t want to show the PivotChart in the Table we can say we don’t want the Chart Type as PivotChart.




 
 If you want to show PivotChart then we have to switch off the other options.




 
 It is important to understand that once you change the Chart Type to “PivotChart” then PivotChart is the only option. You can’t set Chart Type as both PivotChart and Chart.




 
 If you set Chart Type as both PivotChart and Chart, then you will not be able to see the PivotChart Data.




Refresh a PivotChart




To refresh a PivotChart, you will need to open a PivotChart first. We will then be ready to remove or add data. Finally, we will refresh the chart for displaying the latest data.



To begin:




 
 Let’s open a PivotChart first. For instance, the chart displays information of the sales department A, which is the sales department you work in. However, the sales department is not named.




 
 If you click on the Department name, you will see how many sales they made. However, if you want to view only sales made by you, then we will not have to use this information.




 
 To remove the Department name from the chart, we will need to remove the data.




 
 As an example, I will assume that you work in the Sales Department A. I will then remove the data from the Sales Department A. I will then display the updated chart.




 
 Open the PivotChart in PivotChart Wizard.




 
 Open the drop-down menu in the PivotChart area and select Edit Data in a Worksheet.




 
 Click OK.



You will notice that you are removing all the data from the chart: If you want to remove the other data, you will need to follow the same steps.



Let’s refresh the chart now to show the latest data.




 
 As an example, I will assume that you work in the Sales Department A. I will then remove the data from the Sales Department A. I will then refresh the chart for displaying the updated data.




 
 Open the PivotChart in PivotChart Wizard.




 
 Open the drop-down menu in the PivotChart area and select Refresh.




 
 Click OK.



As you can see, the chart has refreshed and you can now view the latest data.








Modify PivotChart Elements




You can create and modify the elements that make up a PivotChart. The following topics describe how to modify and create the elements of the PivotChart:




 
 If you want to modify an existing element, you can open it by using the Open Element from the PivotChart menu or double-click it.




 
 If you want to make a new PivotChart element, you can create it by using the New Element from the PivotChart menu or by right-clicking and choosing New PivotChart Element.



You can make changes to PivotChart elements in the three places that you make most changes to PivotCharts:




 
 The Elements tab.




 
 The Insert tab.




 
 The Design tab.



You can make changes to all the PivotChart elements in a chart from these three places.



To make changes in the Elements tab:




 
 Open the PivotChart.




 
 Click the element in the Elements tab that you want to change.



Tip:



Use the arrow keys on your keyboard to move between elements on the Elements tab.



In the Properties pane, make changes in the Properties pane to the element you just opened.



To make changes in the Insert tab




 
 Open the PivotChart.




 
 Click the element in the Insert tab that you want to change.



Tip:



You can double-click a chart element in the Insert tab to open it. Then, in the Properties pane, make changes to the element.



In the Properties pane, make changes in the Properties pane to the element you just opened.



To make changes in the Design tab




 
 Open the PivotChart.




 
 Right-click any PivotChart element and then click Duplicate.



Tip:



Double-click a chart element to make a duplicate.



If you copied a new chart element that is on the same page, the Design tab displays a new empty page in the right pane for you to add elements. If you copied a new chart element that is on another page, the Design tab displays the empty page with the element on the page you copied the element to.



To add more PivotChart elements, follow the steps in the next section, “Adding Chart Elements to a Chart.”



PivotChart supports adding chart elements to existing charts. Adding chart elements to a PivotChart creates new charts that show information similar to that shown by the charts on the original page. You can make a chart show information about any page in the report. For example, you can create a sales report chart that shows information about sales data from any date. You can make a pie chart show information about the sales for a specific product. In the following steps, you will create a pie chart that shows information about sales for a product for every month of a year.



To create a new chart:




 
 If you have a PivotChart open, go to any chart element in the PivotChart.




 
 Right-click the element.




 
 Select Duplicate Chart.



If you copied a new chart element that is on the same page, the Design tab displays a new empty page in the right pane for you to add elements. If you copied a new chart element that is on another page, the Design tab displays the empty page with the element on the page you copied the element to.



Tip:



Double-click a chart element to make a duplicate.



If you copied a new chart element that is on the same page, the Properties pane displays a new page in the lower half of the right pane. If you copied a new chart element that is on another page, the Properties pane displays the empty page with the element on the page you copied the element to.



Select a chart element.




 
 In the Properties pane, on the Appearance tab, click the button to the right of the Data Scale section.




 
 The Data Scale section of the Appearance tab displays.




 
 Select a new field that you want to use to create your pie chart.




 
 If you have multiple fields to choose from, use the Select field list at the bottom of the window to select a field.




 
 Make sure the box is selected next to Show data for.




 
 In the Pie Chart panel, select the appropriate category.




 
 Click OK.








Apply a PivotChart Style




By using a PivotChart Style object, you can apply the formatting to the chart that you specify. The chart itself does not display the PivotChart Style. You can then specify how the style will appear on the charts that are linked to the PivotChart.



Note: If you’re working with data that has any relationship to the user’s Office environment or operating system, such as dates and times, you may need to make certain settings in the user’s options.



See [Excel Options, Excel Options].



See [Formatting PivotCharts, PivotCharts] for more information about formatting a PivotChart.



Use this method to apply a PivotChart Style to a chart. You can use the same PivotChart Style as you do when you apply the style to the chart.




 
 Syntax




 
 Parameters








Enable PivotChart Drill Down




This sub-chapter describes the ways to use the PivotChart tools to drill down a chart or pivot table so that you can quickly navigate through the hierarchy. For example, you might need to drill down from a summary level of customer information (region, product line, customer type) to a more detailed level (for each region, which products have been sold to each customer type), or drill down to a more detailed level to determine sales figures by product for a given customer type.



PivotChart Tools: To use the PivotChart tools, you must start with a PivotChart that is already in the PivotChart Tools window (as shown in the figure below).




 
 Select a field, click the down arrow, and then select Drill Down to select a more detailed level of the hierarchy.




 
 After you drill down, the selected field takes on a new level of hierarchy. To drill down further, repeat the process to select another field and then select Drill Down again.




 
 Select one or more fields, click the New icon, and then select Create New PivotChart. This action creates a new pivot chart that is connected to the existing pivot chart. The new pivot chart appears in the PivotChart Tools window and can be added to other pivot charts in the PivotChart window.



When you create a new pivot chart, you can include an additional field (such as a subcategory field or additional measure field) or filter (such as a region, time period, or category in the PivotChart window.




 
 Select fields, right-click, and then select Drill Up to select a higher level of the hierarchy.




 
 Repeat the process as many times as necessary to navigate the hierarchy.








The PivotTable Fields




PivotTable Fields:




 
 The PivotTable Filters Allows the user to filter data from a pivot table.




 
 The PivotTable Page Set-up Tools The tools that control the appearance and function of the PivotTable.




 
 The PivotTable Sorting Tools The tools that control the sorting order within the PivotTable.




 
 The PivotTable Layout Tools The tools that control the layout of the PivotTable.




 
 The PivotTable Report Filters The filters that control the PivotTable reports.




 
 The PivotTable Report Layout Tools The tools that control the layout of the PivotTable reports.




 
 The PivotTable Row Groups Allows grouping rows of a PivotTable by a common field.




 
 The PivotTable Row Groups Layout Controls how the grouped rows of a PivotTable appear.




 
 The PivotTable Report Filters Allows the user to filter data from a PivotTable.




 
 The PivotTable Tab Tools The tools that control the tabulation of the PivotTable.




 
 The PivotTable Tab Layout Controls how the fields of the PivotTable appear.




 
 The PivotTable Table of Contents The area on the PivotTable where the fields are summarized.




 
 The PivotTable Fields The controls that allow the user to add extra columns to the PivotTable.




 
 The PivotTable Fields Layout Controls how the PivotTable fields are presented.




 
 The PivotTable Filters The controls that allow the user to filter data from a PivotTable.




 
 The PivotTable Fields The controls that allow the user to add extra columns to the PivotTable.




 
 The PivotTable Row Groups The controls that allow grouping rows of a PivotTable by a common field.




 
 The PivotTable Row Groups Layout Controls how the grouped rows of a PivotTable appear.




 
 The PivotTable Row Groups Allows grouping rows of a PivotTable by a common field.




 
 The PivotTable Row Groups Layout Controls how the grouped rows of a PivotTable appear.




 
 The PivotTable Row Groups Allows grouping rows of a PivotTable by a common field.




 
 The PivotTable Row Groups Layout Controls how the grouped rows of a PivotTable appear.




 
 The PivotTable Row Groups Allows grouping rows of a PivotTable by a common field.




 
 The PivotTable Row Groups Layout Controls how the grouped rows of a PivotTable appear.




 
 The PivotTable Row Groups Allows grouping rows of a PivotTable by a common field.




 
 The PivotTable Row Groups Layout Controls how the grouped rows of a PivotTable appear.








The Layout Group




The Layout Group is a very powerful and useful group that has become a standard way to define layout and grouping of items within a worksheet. Unfortunately, most of the time we would like to change the layout of cells, headers, formulas or even charts within a worksheet. This process is very time consuming as you need to locate the cell in which you want to change the layout, then open that cell, change the desired property and close the cell. The process is then repeated for each cell that needs to be changed. And if you make a mistake, you have to go back and correct the changes.



So, in this sub-chapter, I will show you a shortcut that will allow you to open the layout group from any cell in which you want to edit, change the layout and then apply the changes to all the cells in a worksheet.




 
 If you just want to change the style (alignment) of a cell or the color of its text, then refer to the section below titled: “Edit cell text color and alignment”.




 
 To change the Layout of a cell within the Layout group, you simply double click the cell and go into the properties of the cell.



To show the Layout group from any cell, follow the steps described below:




 
 Open your worksheet and go to any cell that is in the Layout group.




 
 Click on the cell to open the Layout properties box. You will notice that there is a blue Layout button.




 
 Click this button to open the Layout Group.




 
 Go to any cell in the worksheet that you want to edit the layout of the cell and click the layout button within the Properties box. Now you will be able to see the Layout properties of that cell.



Note: If you want to create a shortcut to any cell in the layout group, simply double click that cell within the Layout group and follow the above steps.



There are two great benefits to using this feature:




 
 You can edit the layout of any cell in the worksheet in a single click.




 
 And you do not need to go to every cell in the worksheet that you want to change the layout. Just go to the cell that you want to edit and click the layout button.



Note: As you change the property values of the cells within the layout group, all other cells in the group will inherit the changes.



Editing cell text color and alignment.



The Layout group also allows you to change the text color and alignment of any cell in the worksheet. This also works the same way as described above with the Text Color and Alignment property of any cell.




 
 Just go to the Layout group and click the Alignment and Font Color buttons.




 
 You can also right click any cell within the Layout group and select Edit properties to see the properties dialog box for that cell.



Tip:You can also open the properties dialog box for a cell by pressing F2 on your keyboard or from the cell’s menu.



Note: If you change the font color of a cell within the Layout group, that change will also be reflected in the layout and formatting of other cells within the Layout group.



Editing cell border.



You can also change the borders of any cell within the Layout group. Again this works the same as changing the Border property of any cell in the worksheet.




 
 To change the borders of a cell within the Layout group, simply click on the Border Color button.




 
 You can also select the border colors from the drop down list and click the Apply button.



Note: If you want to change the border size of a cell within the Layout group, simply change the value in the Spacing box and click the Apply button.



Note: You can change the border size, color, and location of the bottom border on cells within the Layout group by adjusting the properties of cells using the Border property.




Editing cell formatting




You can change the formatting of any cell within the Layout group. You can also open the properties dialog box for a cell by pressing F2 on your keyboard or from the cell’s menu.



Note: If you want to change the alignment or font color of a cell within the Layout group, simply change the properties of the cell using the Text Color and Alignment property.
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Macros




Macro is simply a software program that performs a series of commands on the Microsoft Excel worksheets”. It is used to automate some specific task. Macros can be used to add some features, and can also be used to automate repetitive tasks. In some cases, you can make a macro in Excel.



An excel macro enables you to perform a task in a specific way. Macros can be created in many ways. A programmer can use an excel macro programming technique to create macros. You can also use Macro Recorder to create a macro. In this article, we will show you how to use excel Macros to add text in Excel spreadsheet.



In general, an Excel macro enables you to create your own custom solutions for any kind of operation on your spreadsheets.







How to Create a Macro in Excel Spreadsheet: It is easy to create a macro in Excel.




 
 Create a New Excel Sheet and insert any table (for example, create a table named “My Table”)




 
 Now, click on the Table Tools ribbon, and click on the Create and Formatting button. You will see two panes on the screen.




 
 In the second pane, click on the Macros button. Here, you will find a lot of Macros for formatting, formulas, text formatting, etc.



Now, we will discuss on how to use Excel Macros to add text in Excel.




 
 To add a new text in Excel, you will need to have an Excel Sheet and a Macro Enabled. In order to add a new text, click on the Home button.




 
 You will find the Edit menu on the ribbon.




 
 The “Add” command is on the menu.




 
 Now, you will be able to add the text to the spreadsheet.




 
 Now, you can change the text style in the same way you change the text style.




How to Insert an Excel Macro




Inserting Excel Macro is the process in which you can add a code to a cell and then use it anywhere in the worksheet. This allows you to customize your macros in a way that you want.




 
 Go to the Home tab, and click on the Insert option. Now, click on the Macros button.




 
 You will find the Macro Manager in this pane.




 
 Now, you can create your own customized macros. For example, you can create a macro to write the date to a cell or a text.




 
 To create a new macro, click on the New button.




 
 You can name the macro. Then, click on the OK button.




 
 Once you are done, click on the OK button.




Enable the Developer Tab




To start with, Microsoft excel version 2021 and lower versions, say from 2010, ‘enable developer’ tools by default. There is an option to show/hide the developer tab in all excel sheets, but you have to turn this on manually.



To turn this feature on,you will have to follow the below steps:




 
 Click on Tools - Developer - Microsoft Excel Options.




 
 At the bottom there will be an option that says to enable the developer tab




 
 Click on this and then press ok and close the options window




 
 The developer tab will be visible on the tab bar (shown in the figure).








Record a Macro




To start a macro recording, you need to



1. open your VBA editor



2. insert a line where you want the macro code to be



3. paste in the code you would like to run



4. click record



5. once complete, the code will appear below the code you entered



6. you can stop the recording by pressing Esc







Then to execute the macro



1. run it by clicking run macro in the VBA window



2. you will need to paste in the macro code again



3. then press Enter or click done to exit the macro recording



The reason it’s so easy is you don’t need to edit any lines. When you start the recording, your mouse will follow where the cursor goes.








Run a Macro




To run a macro, you can always look at the code generated by the macro recorder. They use a “Sub” to make the changes, that is essentially the equivalent of a ‘function’. You can then read the code to see if there is anything you want to do yourself. That is, provided you can modify the code in any way you wish.



The trick is to find the code generated when you run the macro.




 
 Go to the macro and right-click, then click Run Macro Recorder. This gives you the VBA code (which you can edit) but also includes the Excel code. You have to know the starting point to add code to change the Excel cells that you want to change.




 
 The line that the macro recorder adds to the end of the macro is this:



Range(”C2”).Select



Range(”C2”).EntireRow.Insert



Range(”C2”).Value = “NewCellValue”



Range(”C2”).Copy



Range(”C3”).PasteSpecial Paste:=xlPasteValues



Application.CutCopyMode = False



I add the code before that line. This will replace every cell in column C with “NewCellValue”. You will have to write code to get to the cells you want to change, since there are no named ranges. I have changed every instance of the text in column C to the word “test”.








Edit a Macro




There are two ways to edit an existing macro:




 
 Open the macro you want to change in Excel and click the Edit button in the lower left of the toolbar. That will open the Macro dialog, where you can make changes.




 
 Use the macro recorder to record a new macro. Then open the macro recorder in Excel. When recording, the macro recorder shows you the dialog boxes it would show you if you were to record the macro. The easiest way to change your dialog boxes is to just click in the dialog boxes.








Delete a Macro




To delete a Macro, let’s begin by opening Excel and create a Macro. Click on the FILE menu and select the NEW window to create a new Macro named “Macro Name”.




 
 Once the Macro gets created and saved in a location, we can delete it by using the menu View > Macros > Macros.




 
 If you want to restore a Macro back to its original state. Then just select the Macro and click on the Undo Button and you will have a Macro back in a same state as it was earlier.




 
 If you wish to remove any macro from a workbook, just select the macro you wish to delete and click on the x button.








Macro Security




The Macro security is set to prevent malicious changes to the spreadsheet. It makes sure that malicious code will not be executed or run. These functions are used to prevent unwanted changes to the data such as changing the name of the cells, row, columns or to make the formulas to not work.



How to add macro security: There are two ways to remove the macro security in excel.




 
 Either you can go to Excel menu -> File -> Options -> Trust Center -> Trust Center Settings and there you can find a checkbox named, ‘Disable all macros, add-ins, and VBA projects’ to set it to disable.




 
 Or you can go to Excel menu -> Tools -> Options -> Trust Center -> Trust Center Settings and there you can find a checkbox named, ‘Prevent macros and ActiveX Controls from running on this computer’ to set it to prevent.




Why is macro security useful?




Macro security is helpful when you use Excel because it can prevent you from entering different macros and changing the formulas in the sheet. For example, if you are working with a sensitive report with sensitive data and you want to show it to your boss, but you do not want your boss to make any changes to the data in that sheet, the macro can be a way to show them how to change the spreadsheet so they can use that part. This is also a best practice to not have macro security turned on because it can prevent changes and unwanted code to enter and run.



When a macro is added, there is a small box next to it that reads, “This workbook is protected by macros.” If a macro is protected by macros, then you can add macro or any kind of code such as a virus. If you do not add a macro and there is no code, this worksheet can be edited normally and changes will not be applied to the data.


















CHAPTER TWENTY





Troubleshoot Formulas




Formulas are used to create custom reports and other calculations. In the example above, the formula returns the value of the third column “F12”.



If you are new to Excel formulas, a formula has two parts: the part before the equals sign is called the “operand” and the part after the equals sign is called the “value”. They are separated by a period. Thus, in the example above, the operand of the formula is “D12” and the value is “$1.5″. These parts need to be written as individual cells on the Excel page. If you select one of the cells and enter the formula into the formula bar (the bar containing the “=” sign) at the top, it should return $1.5.



In most cases, a formula doesn’t return an exact value. It only returns the information you want it to return. To learn more about formulas, see Using the Formula Bar. Formulas in Excel are used to calculate the values in cells (or ranges of cells). They are very powerful and are at the heart of advanced spreadsheet calculation. The most basic formula is =[cell]. To apply the formula to a cell, drag the formula across the column heading or across the row heading. Enter the data into the cells and then check the answer in the Result column.








Common Formula Errors




Microsoft excel and the use of its functions have become an everyday thing in today’s world. In fact, without the use of excel, you can’t live life. When you first find yourself having difficulties in making excel-based formulas work, it is only a matter of time before you will have to find the problem. So how do you do that? It is very important to find out what is going on.



In this sub-chapter, you’ll discover why the use of the common formula errors has been so widely spread in the modern day world. You’ll also discover the ways that you can get rid of them. Read on and learn how to fix all those common formula errors.



1. Using incorrect cell references



In the last decade, there’s no doubt that the use of excel formulas has become common among users. But what does that mean? It means that in a lot of times, the use of different cell references has led to different formula errors.



For example, most people in the past were using “Y2”, “A2” and “H2”. These are all different references, and for them to work properly, the Excel cell references must be the same as the cell names on the worksheet. But nowadays, people are now using the letter “B”, which is a cell reference that isn’t being used in many modern day computers.



This is just a small example of the wide-spread use of cell references, and if you’re using Excel’s functions, you may be experiencing similar formula errors. A good example of this could be the formula that looks like this: =A5+5. If you’re using this formula, you’re going to be using the formula from the cell that has the letter “A” in it. But what if the formula is =A3+5? The answer will be the same, but in this case, you’re going to use a different cell reference. In this case, you need to add the cell reference manually.







2. Using incorrect function names



There’s no doubt that excel formulas are some of the most powerful formulas in the world. They provide a wide range of solutions to a wide range of problems. But one of the worst practices people use is to name their formulas incorrectly. This error comes from many different sources. For starters, a lot of Excel formulas are called by adding the name of a formula onto the function that they are calling. As a result, many people think that naming a formula “=A3+1” is going to produce the same results as “=A3+1”. Unfortunately, it will not.



A lot of people have this mistaken belief about formulas, and this is what causes their mistakes. You have to name your formulas correctly in order to get the results you’re expecting. If the formula that you’re trying to use isn’t named correctly, it will not produce the results you need. In many cases, the name you give your function will determine whether the formula works or not.







3. Using function names that don’t exist



Sometimes, people don’t use functions that exist, and because of this, they’re using the incorrect formula. This can result in all sorts of unexpected problems in your excel formulas. Some of the most common formulas people try to use are: =B9, =INDEX(B3,2), =INDEX(B3,4), etc. These formulas will not work as they are intended.



There are three main reasons that you need to stop using these functions. The first thing is that they’re actually not in Excel. The second thing is that they may have unintended consequences. Finally, you shouldn’t be using these formulas in the first place.



There’s a simple rule you should follow when you’re using Excel formulas. You should always use the name of the function in your formula, not the formula itself. If your formula is called =A3+1, you shouldn’t be using A3+1 as the name. It will make a mess of your formulas and cause all sorts of problems. You need to always use the proper formula name.



The last tip we have is to make sure that you use the proper calculation when using formulas. The most common problem with formulas is that they’re being used to do different things in different cells. Because of this, it’s likely that you’ll end up with an answer that isn’t what you want. The Excel functions are designed to calculate one thing.








Error Checking




Error checking on Microsoft excels can be done using code like this,




 
 On Error GoTo ErrHandler




 
 DoCmd.SaveAs Filename:=<name of save file>, WriteResError:=ErrHandler




 
 Exit Sub



So that’s one way. Here’s another.




 
 Sub AddToSheet()




 
 ‘AddThisDataSheet




 
 ThisWorkbook.Worksheets(1).Columns(”B:B”).Insert Shift:=xlToRight




 
 End Sub



Sub DeleteSheet()




 
 ‘ DeleteThisDataSheet




 
 ThisWorkbook.Worksheets(1).Rows(1).Delete Shift:=xlUp




 
 End Sub



Sub DoCmd()




 
 ‘AddThisDataSheet




 
 ThisWorkbook.Worksheets(1).Columns(”B:B”).Insert Shift:=xlToRight




 
 DoCmd.RunSQL “DELETE * FROM [ThisDataSheet$




 
 End Sub



Sub DeleteThisDataSheet()




 
 ‘ DeleteThisDataSheet




 
 ThisWorkbook.Worksheets(1).Rows(1).Delete Shift:=xlUp




 
 End Sub



Sub ErrorHandler()




 
 MsgBox “Error encountered.”, vbCritical




 
 GoTo ExitSub




 
 End Sub








The Watch Window




The Watch Window is a graphical user interface for monitoring the data in Excel. It enables you to monitor changes in a selected range and to get instant email notification when data changes. You can use it to quickly notify yourself or others of data changes in your workbooks. It is an add-in for Microsoft Excel which enables you to get notification of any changes to a range within a workbook. When a change is made to the values in a cell, you receive a notification that will allow you to choose whether to view the new or the old value. It’s simple to use - just set a range for the workbook that you want to monitor and the range will be updated every time there is a change. You can set up rules that will let you know when cells within that range have changed. It works best if your workbook is open. However, you can monitor any Excel workbook.



Note: In the following tutorial, we will use the cell range: Range(”C3:G5”).



Step 1.



Make sure that Excel is open. Click File > Open to open Excel and navigate to your Workbooks folder. Navigate to the folder where your Workbook resides. You should see a file with the name of your Workbook with a document icon. Double-click the file to open it.



Step 2.



Right-click on the Workbook and select Excel Options from the menu.



Step 3.



Choose Accessibility and then change the Use Accessibility Feature to Always. You can click OK to save your changes and exit the Options window.



Step 4.



From the File menu, click Watch Window.



Step 5.



In the Watch window, you will notice that a new item has been added in the Ribbon. Click on it and a new item is added on the Ribbon with the name “Watch” and the icon of the Watch Window. You can now start monitoring changes to the range in a workbook. To start monitoring the range:



Step 6.



Right-click on the cell range that you want to monitor and click Watch.



Step 7.



You will notice that a small window pops up at the right side of the Data Tab in Excel. This is where you can monitor the cell range.



Step 8.



If a change is detected, you will get a notification to let you know about it. Click on the “i” icon to view the new value.



Step 9.



To stop monitoring the cell range, right-click on the range and click Unwatch.



Note: To remove the Watch feature completely, right-click on the range that you want to monitor and choose “Remove Watch.” To remove the notification window, right-click on it and choose “Remove Notification Window.”








Evaluate a Formula




There are two approaches to evaluate a formula in Microsoft excel.



Using the Excel Evaluate command:




 
 Click on the cell in which you want to do the calculation.




 
 Insert a formula using the Insert > Formula or Formulae bar.




 
 Click on the Evaluate button to the right of the Formula bar.



This will return the value that was placed in the cell.







Using a Python Application and an Excel COM Object:



In this case, you will need to add the Excel COM object to your python application and then you will be able to use the COM objects to access the Excel Object Model from your Python application. There are a lot of resources and questions on StackOverflow about doing this.



For example, you could do something like this;



d = Dispatch(”Excel.Application”)



d. Visible = True



xlsheet = d.Workbooks.Add()



xlsheet.Cells(0,0) = ‘1’



xlsheet.Cells(1,0) = ‘2’



xlsheet.Cells(2,0) = ‘3’







xlsheet.Cells(1,0).Formula = ‘=SUM(3*F(y;x))’



print xlsheet.Cells(1,0).Formula



Which would result in the cell returning the value of 7.







The problem is that SUM evaluates the array F(y;x) as a single value, which is 8. This can be seen in the formula. Using SUM() and F(), it is possible to have the function evaluate an array using the SUM() formula. To obtain the array of values that a function returns, an “IF()” statement can be used:



=SUM(IF(F(1,1)=4,3,0))



The cell referenced by F(1,1) is the first column of the current row (F(y) for the Yth row). So what you need to do is to have the cell you want to use the array function F in read:



xlsheet.Cells(1,0).Formula = ‘=SUM(3*F(y;x))’



xlsheet.Cells(1,0).Value = 3



xlsheet.Cells(1,0).DisplayExcel = False



Here are some other examples on how to use functions F to work with arrays.








Using Excel array functions in Excel formula




xlsheet.Cells(1,0).Formula = ‘=SUM(3*F(y;x))’



xlsheet.Cells(1,0).Value = 3



xlsheet.Cells(1,0).DisplayExcel = False


















CHAPTER TWENTY-ONE





 
Advanced Formatting




Advanced Formatting on Microsoft excel is essential for getting good results, it includes setting up of columns, rows and fonts; there are many methods to setup columns, rows and fonts. This is an important part of formatting, we all know what a number says, its numbers, but we need to use a font for it, a font helps us to read the numbers easily. Excel does have the facilities to set all these, however these are the general settings for all the cells. But we can adjust our columns and rows to align all the content under those. There are many methods for using formatting in excel, and all the methods have its own advantages. Formatting has various methods, some of them are the same, like the way to set the background, font, color, alignment, row and column etc. But we can set the data of the cell in columns and rows. And these all are general formatting methods; we can change our formatting easily by using some special methods.



In first step, we will focus on setting the font of our content. For this, we have two methods to use



1) Home -> Cell Styles -> Format Cells



2) Select the cells and select the desired option -> Cell Styles -> “Font”



For both of these methods, we will select the “Font” option for setting up the font. But using the Cell Styles is the best option. Using the Cell Styles, you can set the font size, color, alignment, font type, and many other options. We have many more options like for cell fill, and background fill. For the background fill you can select the color and shade that are the most popular. As we all know how to set the cell background, but the methods are bit different. For the setting the background, we have two methods



1) Select the cells, then go to the “Fill” option



2) Select the option “Select or Fill”



In the first method, we can select the color as per our preference. We can also check the range by selecting the cells and then selecting the option “Select Columns”. Or else, we can use the “Cells”, “Left”, “Right” or “All”.



For setting the background color using the “Select or Fill”, we can select the desired color using the picker, or by dragging the color from the palette, using the “Select or Fill” option.



For cell fill, we can use the same option. You can select the desired color using the picker, or by dragging the color from the palette, using the “Fill” option.




 
 Using the cells, go to the “Font” option and select the desired font color




 
 Using the option “Fill”, or “Select or Fill”, select the desired font color




 
 You can set the font color also using the options of the Font Type




 
 You can use the same option that you have used to set the font size in the cell styles. It is easy to do




 
 Using the “Font”, “Fill”, or “Select or Fill”, select the desired font




 
 Using the “Font Type”, you can easily set different font styles. In the default font style, there are three font styles that are “Normal”, “Italic” and “Bold”. We can select any one of them, according to our preference




 
 For the three styles: “Normal”, “Italic” and “Bold”, there are three font styles




 
 Using the same “Font Type”, you can use the font sizes that you had used in the cell styles. For the three styles: “Normal”, “Italic” and “Bold”, there are three font styles




 
 Using the “Font Type”, we can also use the font kerning and the font drop shadow. By using the “Font Type”, we can also use the font kerning and the font drop shadow




 
 Using the “Font Type”, we can also use the “Font color”, “Font size” and the “FontSize”. Using the “Font Type”, we can also use the “Font color”, “Font size” and the “FontSize”. For setting the font




 
 Using the “Font”, “Fill”, or “Select or Fill”, select the desired font color. For setting the font




 
 You can set the font color also using the options of the Font Type




 
 You can select the text position. For setting the text position: You can use “Top”, “Center” and “Bottom




 
 You can select the text height. For setting the text height: You can use “Default”, “Single”, “Double”, “Triple” and “Quadruple




 
 You can select the text thickness. For setting the text thickness: You can use “Thin”, “Medium”, “Thick




 
 You can set the text vertical alignment. For setting the text vertical alignment: You can use “Top








Customize Conditional Formatting




The ability to change the appearance of your data using conditional formatting. This technique would give you the flexibility to change the formatting for one particular data and not others. Let’s understand this further.




What is conditional formatting?




It’s all about changing the formatting of your cell data based on specific criteria you provide. In simple words, this technique enables you to change the color of a cell based on certain criteria. In short, you may not apply any formatting to some cells but you can change the formatting of one or more specific cells. Conditional formatting in Excel provides different types of formatting options that you can add in your excel workbook. In this example, we have added “Text Box” conditional formatting.




What are the options for conditional formatting?




There are different types of conditional formatting. Let’s understand some of the different options here.



Color: We can change the color of the data based on different criteria. You can apply “Color” conditional formatting if you want to change the color of a cell based on a specific range or value of a particular cell.



Font: We can change the font of the cell data based on a specific value or range. This is called “Font” conditional formatting. We can also change the font size based on a certain value or range. You can apply “Font” conditional formatting if you want to change the font of a cell based on a specific value or range.



Thickness: We can change the thickness of a cell based on a certain value or range. You can apply “Thickness” conditional formatting if you want to change the thickness of a cell based on a specific value or range.



Size: We can change the size of a cell based on a certain value or range. You can apply “Size” conditional formatting if you want to change the size of a cell based on a specific value or range.



Fill: We can change the fill color of a cell based on a certain value or range. You can apply “Fill” conditional formatting if you want to change the fill color of a cell based on a specific value or range.



Picture: We can change the image of the cell based on a certain value or range. You can apply “Picture” conditional formatting if you want to change the image of the cell based on a specific value or range.



Date and Time: We can change the date and time of a cell based on a specific value or range. You can apply “Date and Time” conditional formatting if you want to change the date and time of a cell based on a specific value or range.



Special Formula: We can change the formula of a cell based on a specific value or range. You can apply “Special Formula” conditional formatting if you want to change the formula of a cell based on a specific value or range.



If you want to change the formatting option of a cell, the way to do this is simple. Just highlight the cell on which you want to apply the formatting. After this, you can click the Format button.




Conditional formatting tips





 
 You can use conditional formatting to hide a row or column from a view based on a specific condition.



There are many ways to apply conditional formatting. You can use this conditional formatting in the following cases:




 
 You want to display information or content based on certain values.




 
 You want to hide some information or content on a specific row.




 
 You want to change the formatting of a cell based on a specific condition.



We can use conditional formatting for many other purposes. However, it is easier to understand if we use it to hide information or content.








Change the Order of Conditional Formatting Rules




Conditional formatting doesn’t really support reordering rules. You’re really limited to swapping rows and columns. However, the easiest way to do this is to copy the range containing the rule and paste it in the new order.




 
 If the new rule will be pasted over the top of the existing rule, just paste it over. If the new rule will go below the existing rule, just drag the paste button to place the new rule underneath the existing rule.




 
 There are probably other ways to do this as well, like inserting it in the new order before formatting and then removing the original formatting. But the method above works well in the majority of situations.



In cell B1 you have the following formula:



=AND(ISNUMBER(MATCH(I1,$A:$A,0))=TRUE,ISNUMBER(MATCH(I2,$A:$A,0))=TRUE)



This means you want to have the following conditional formatting rule:



If both I1 and I2 are numbers and I1 is less than I2, color the cell yellow.



If both I1 and I2 are numbers and I2 is less than I1, color the cell yellow.



If only I1 is a number, color the cell yellow.



If only I2 is a number, color the cell yellow.



It is also possible to apply the rule differently based on the status of cell B1 itself. This can be done by having the following formula in the conditional formatting rule:



=B1=True



This means you can set the conditional formatting rule as:



If B1 is True and both I1 and I2 are numbers and I1 is less than I2, color the cell yellow.



If B1 is True and both I1 and I2 are numbers and I2 is less than I1, color the cell yellow.



If B1 is True and only I1 is a number, color the cell yellow.



If B1 is True and only I2 is a number, color the cell yellow.







	
Goal Seek





“I would like to do a Goal seek on an excel sheet with a date. (My excel data looks like this)



Year Month Day Value



2020 1 1 3



2020 1 2 5



How can I do a Goal seek for the 1st row to find the first date it is greater than 5 and use that row as the starting value for my goal seek? Basically I want to do a Goal seek on “2020” and have it output the result of 4/23/2020. I also need to be able to add the “Date” to the dataframe so I don’t have to modify the date on the date column by hand.”



With 2022 version of Excel, it’s fairly simple:




 
 Go to Data > Data Tools > Goal Seek > Create




 
 Click OK.



Then make sure your cell is selected in your data set (A4 for the example below).




 
 Go to Data > Data Tools > Goal Seek.




 
 Click “Create Goal Seek,”




 
 And you have your starting cell, and then click “OK”.



A4




 
 Click OK in your new dialog box. The goal value has been set in the data row, and you can now click “OK”. Now you can select all columns to the right of the Goal seek dialog box (in the current cell range of A4 to G6 in the example below).




 
 Go to Data > Data Tools > Goal Seek > OK.




 
 You can now right click the start row (A4) to see the Goal seek dialog. Right click the end row (in this example G6), and choose “Go To”.




 
 Then right click the new cell range in my workbook (A4:G6 in the example below)




 
 Choose “Paste as values”



I am not sure if this will work, but try below in case




 
 Right click on Value cell and click Data tab > Formula




 
 Now enter the formula for your goal seek and the name of the date column in the formula bar in place of :



=<Goal Seek start>



and =<Goal Seek end>



Note:



=Goal Seek <Range1> <Range2> - Range1 can be the cell you are entering data in and Range2 should be the cell that contains Goal Seek start and Goal Seek end, if these 2 cells don’t have same number of rows, then enter the number of rows from first cell to the last cell to be evaluated. Enter and select Value1 and Value2 from the option in the box on the right side. (I assumed Goal Seek Start and Goal Seek End are the same)
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Advanced Formulas




The ADVANCED FORMULAS feature in MS Excel allows you to write a formula that produces a result based on the value(s) in the top row of an entire column, and also based on the value(s) in the top row of another column. For example, let’s say that you are asked to produce an invoice that includes an itemized charge for each of four employees. Let’s assume that the top row of each of the four employees’ Charge Sheets contains a value that is the total amount owed to each employee for his services. In that case, you would enter the charge for each employee in a single column. Since the column header already gives the total amount, this would simply be the sum of the four employee charge amounts. Then, you would need to produce a charge line for each employee, based on the charge amount for that employee in the first row of that employee’s Charge Sheet.



In this chapter, we will be looking at advanced formulas on Excel 2021 to make complex math formulas. Formulas are like a magic where you can do certain calculations like calculating discounts on products or the price of different products, calculating a net profit and much more. As the saying goes “nothing is better than good math,” we will explore some advanced math formulas that will make you a true Excel wizard. For this purpose we will be discussing how to solve some very complex math equations, mathematical equations that you find difficult to solve on a paper.



The first formula we will be looking at is the sum of a series. Suppose that we are given a set of numbers for which we need to know their sum. We will look at how to do this with excel.




 
 To calculate the sum we use the SUMIF function. The formula that we use is as follows:



=SUMIF(A1:A100,”>”,B1:B100)



If you have any doubts in formulas, you can read this guide on how to calculate the formula to calculate the sum.




 
 We also have the following formula which we use to calculate the subtraction of a series of numbers. To calculate this formula we use the SUMIFS function. The formula is as follows:



=SUMIFS(A1:A100,B1:B100,”>”,C1:C100)




 
 The following formula calculates the difference of a series of numbers. To calculate this formula, we use the SUMIF function again. The formula is as follows:



=SUMIF(A1:A100,B1:B100,”<”)




 
 The following formula calculates the sum of all the numbers in the series. To calculate this formula we use the SUM function. The formula is as follows:



=SUM(A1:A100)




 
 The following formula calculates the sum of the first 100 numbers of the series. To calculate this formula we use the SUMIF function. The formula is as follows:



=SUMIF(A1:A100,”>”,B1:B100)




 
 The following formula calculates the difference of all the numbers in the series. To calculate this formula we use the SUMIFS function. The formula is as follows:



=SUMIFS(A1:A100,B1:B100,”>”,C1:C100)




 
 The following formula calculates the sum of all the numbers in the series. To calculate this formula we use the SUM function. The formula is as follows:



=SUM(A1:A100)




 
 The following formula calculates the difference of all the numbers in the series. To calculate this formula we use the SUMIF function. The formula is as follows:



=SUMIF(A1:A100,”<”,B1:B100)




 
 The following formula calculates the sum of the 100 highest numbers in the series. To calculate this formula we use the SUMIF function. The formula is as follows:



=SUMIF(A1:A100,MAX(A1:A100),B1:B100)




 
 The following formula calculates the average of the numbers in the series. To calculate this formula we use the AVERAGEIF function. The formula is as follows:



=AVERAGEIF (A1:A100,B1:B100)




 
 The following formula calculates the sum of the numbers in the series that are not in the set A. To calculate this formula we use the SUMIF function. The formula is as follows:



=SUMIF(A1:A100,B1:B100,”>”)




 
 The following formula calculates the count of the values of the series that are larger than 50. To calculate this formula we use the COUNTIF function. The formula is as follows:



=COUNTIF(A1:A100,”>”)




 
 The following formula calculates the sum of all the numbers that are in the series. To calculate this formula we use the SUM function. The formula is as follows:



=SUM(A1:A100)




 
 The following formula calculates the average of the numbers in the series. To calculate this formula we use the AVERAGE function. The formula is as follows:



=AVERAGE(A1:A100)




 
 The following formula calculates the total of the numbers in the series. To calculate this formula we use the SUM function. The formula is as follows:



=SUM(A1:A100)




 
 The following formula calculates the largest number in the series. To calculate this formula we use the MAX function. The formula is as follows:



=MAX(A1:A100)




 
 The following formula calculates the smallest number in the series. To calculate this formula we use the MIN function. The formula is as follows:



=MIN(A1:A100)




 
 The following formula calculates the product of the values of the series that are in the set A. To calculate this formula we use the PRODUCT function. The formula is as follows:



=PRODUCT(A1:A100)








Nested Functions




Nested Functions are the basic feature that we use to increase our productivity and to simplify our day-to-day work. It increases the effectiveness and helps to streamline data.



Nested functions are a very essential tool for Microsoft excel and its user. By using the Nested functions you can not only automate your day-to-day tasks but it can also enhance the data analysis, data cleansing and cleansing results in a better way.



Nested functions are basically a collection of formulas. If you are performing a task and do not need to perform a task again and again then you can create a macro and just perform the macro. Macro is a series of commands and each of the commands is assigned to the macros. In the same way you can create a function in excel. So when you have a task that you need to perform just create a new function that automatically performs your task.



Below are the top 3 things to keep in mind while working with nested functions. These 8 things are vital when you are dealing with the macro.







1. Nested functions – Excel Formula



You need to keep in mind that Nested functions are a series of formulas. While it may seem simple, but it is the one thing that most people don’t know. These functions are basically very basic in nature and they help you perform a task.



Before creating a nested function, you should always think about how you will use it. If you are performing a very long task then you don’t need a nested function to perform that task. If you are a data scientist then you can use the function as a part of a formula to analyse your data. This is the most basic function and you can find them in the dropdown list in excel.



2. Keeps the formula simple



Sometimes when you have too many nested functions then it is easier to perform a task. In such cases if you don’t perform a task again and again then you can create a macro. But, in most cases, you need to perform a task a number of times and the more complicated you make it, the more complicated it becomes. So you need to keep your function simple and that is the first step that you need to consider.



You must have a good knowledge of formula and it helps you to write a good formula. When you create a nested function you need to keep in mind that it has nested formulae. If you have a complex formula then you need to split it into separate functions and that can make your function much simpler.



3. It has a unique feature



Nested functions are much more useful in data analytics than any other function. You have to perform the task of creating a formula and then you need to perform that task over and over again and that can get really annoying.



For example, in the following code, we are extracting the column names that start with certain word and we are performing the task of extracting those names over and over again.



To perform a task which doesn’t require any function, just extract column names that start with certain words. So, find all the names that start with Test and you can assign it to a variable and can use it further.



So, we have to create a function, name it GetNamesFromCell() and use it within the function that extracts the names. For example, this can be achieved by something like this;




 
 Sub GetExactName()



Dim strColumn As String



Dim oName As Name



Dim arrName As Variant



arrName = Array(”Test_1”, “Test_2”, “Test_3”, “Test_4”)




 
 For Each oName In Worksheets(”Sheet2”).Names



If InStr(1, oName.Name, “Test_”) > 0 Then



strColumn = Right(oName.Name, Len(oName.Name) - 6)



End If



Next oName



End Sub



We have a function that gets the name of the columns. We have only created the function to extract the names and we don’t even need to call the function.



The advantage of creating such a function is that we don’t have to write the code to extract the names every time







	
IF





“ I have many sheets with data - and an other sheet with the formula:



=IF(ISBLANK(R2),VLOOKUP(VLOOKUP(R1,$A$1:$B$4,2,0),$A$1:$B$4,2,0),”no value”)



I need to copy this formula all sheets.



How can I make an VBA code in the Microsoft Visual Basic for only one sheet?



I try to use:



Dim c As Range



Set c = ActiveWorkbook.Worksheets(”Sheet1”).Range(”E4”).Select



But it does not work.”



You can just use the Application.Match function which returns the location in the list if the value exists, or returns zero otherwise. For example, in Sheet1:



=IFERROR(Application.Match(”S1”, Sheet2.Columns(4), 0), “not found”)



Edit: if your range is not always the same size and shape (say, in my example it has one column and two rows), then you can use the Application.Match function to look for the first blank cell in the column:



=IFERROR(Application.Match(”S1”, Sheet2.Columns(4), 0), “not found”)



Now, you have to set up the range in a way that will allow for both positive and negative matching. My example only has one row and column, so I can simply use Rows(1). Use this format to look up a range that you can repeat all over your sheet:



=IFERROR(Application.Match(”S1”, Sheet2.Columns(4), 0), “not found”)



It’s much easier to set up a lookup for each range in your spreadsheet, with one column and one row for each range, and repeat down columns in each row. For example, you can use:



=IFERROR(Application.Match(”S1”, Sheet2.Columns(4), 0), “not found”)







	
AND, OR, NOT





“I am trying to find out, if I could have the same outcome if I do something like this:



=IF(R4>R3,NOT(V4=V3),(V4=V3)) I’ve also tried using a case, but I seem to be having trouble with that”







Your formula can be simplified to:



=IF(R4>R3,V4,V3)



The first part can be replaced by TRUE or FALSE depending on what you’re looking for.



The use of =V4, can be replaced with,



IF(R4>R3,”NewVal”,”OldVal”) where “NewVal” and “OldVal” refer to the result values of the IF statement.



To find if one value is the same as another use the AND or ANDNOT functions in Excel.



=AND(R4>R3,V4=V3)



=ANDNOT(R4>R3,V4=V3)



The second condition doesn’t seem like something you’ll be needing in your example, but using this method would allow you to have a general, reusable IF statement.








VLOOKUP



[image: ]



“I have a sheet like this:



What I am trying to do is to look up the column for the “Code 1” to look if it is available in the table of values in the same sheet. If the cell is available the value should appear.



Below is an example of what I am trying to do.



The first row (i) is the column “Code” with some “Cases” but I want the table to read the whole row. How can this be done?”



Assuming that the values in the table are in columns A:F, and the “Code” column has header “Code”, and the table starts at cell G2, then in cell C1:



=IF(ISNUMBER(MATCH(G2, A:F, 0)), G2, “not found”)



Drag down to the bottom of the worksheet.








HLOOKUP








In excel, you could use PIVOT or COUNTIF in a formula such as:



=COUNTIF(T$3:T,0)



COUNTIF(”T3:T” , 0) =COUNTIF(T3:T, “0”)



This will return the number of records in column T where T3:T returns an empty string (i.e. where the text in column T is zero)



In pivot tables you could do the same with a pivot table function such as:



=COUNTIF(Count Total, 0)



=COUNTIF(Count Total, “0”)



Or in other words, for the account listed as “no transactions” you would return a value of zero.



The following worksheet illustrates the use of the first method. It shows that there are two unique items in column B that do not match the criteria in column C. The second method returns two unique items.



If this were a SQL server table, the query:



SELECT a, COUNT(*)



FROM T



GROUP BY a



HAVING COUNT(*)=0, would return the same result.



You may notice that in this particular example I have not yet mentioned the unique IDs that you have available. The use of the unique IDs as the table header is the standard method for identifying the unique entries. It has the advantage of not putting extra formatting in the cells above and below the table. It has the disadvantage of being somewhat slow and more difficult to understand.



In the following example, I have applied a conditional formatting formula to give the unique ID column header a value of either Green, Red, or Yellow based on the value of the cell above it. The results are shown below.



Formula =IF(A2=A3,IF(B2=B3,”Red”,IF(B2=”,IF(C2=C3,Yellow,Green),”)),”)



The second example is based on the same principle but uses the unique ID to return the value of the cell above the row of the cell containing the value that needs to be returned.



Example: Matching the value of column A to the value of column D



Suppose you have a report that uses four dates (today, next Monday, next Friday, and the following Monday) as column headers. You want to make a report that shows the total balance of each date across all months, as shown below.



Now suppose that you want to look up the value in a list in column E. The result will be the value in the right hand column in the following image.



Formula =IF(A1=”May”,”10”,IF(A1=”June”, “20”,IF(A1=”July”, “30”,IF(A1=”August”, “40”,IF(A1=”September”, “50”,IF(A1=”October”, “60”,IF(A1=”November”, “70”,IF(A1=”December”, “80”)



I am hoping this demonstrates to you that if you want to change the background color of the row or column to different colors based on some conditions, it is far more difficult to apply than simply setting a cell value equal to a value from another cell.



In the examples above, I have used the formula directly in a cell. I have also included an application for a simple range-based approach that would be appropriate in many situations








XLOOKUP




For a single value, you would just use a SUMIF formula (SUMIFS is the same thing, but with an OFFSET which is useful to apply to more than one range).



If you want multiple values from the same table, you would want to use the FILTER function to extract the desired table range, like so:



=SUMIF(FILTER(’Data!$A$1:$C$’&B2&’:$B$’&C2,$F$2=$G$2),$H$2)



With that array formula entering a new line. You then press Ctrl-Shift-Enter rather than Enter to enter the new line.



The above formula gives the sum of the data where the first column equals $G$2 and the first column, “F”, matches the corresponding value in the second column.



If the data doesn’t necessarily have to be from a table, you can replace the “Data!” with the name of the sheet which contains your data, and the “$A$1:$C$” can be replaced with a reference to the location you want the values to come from, whether from a table, range, etc.








UPPER, LOWER, and PROPER




Let’s make a function that accepts a table and a series of values. We are going to need a list of integers, so we need to create a list.



def make_list(table, n):



 L = [table[x][’U’] for x in range(len(table))]



 L.insert(0, n)



 L.insert(1, n)



 L.insert(2, n)



 return L




 
 Let’s try it on a sample table:



table = [[’TEST1’, ‘TEST2’, ‘TEST3’], [’A’, ‘B’, ‘C’], [’B’, ‘A’, ‘C’], [’A’, ‘B’, ‘C’]



And n = 1. We can create our list of three values, like so:



>>> make_list(table, 1)




 
 [1, 1, 1]



Now we can sort that list using the comparison function we defined in our previous question. We can do this by passing that into the sorted() function. The sorting needs to be done in place. We’ll pass a function into the sorted() method to swap the second and third elements if the comparison function returns a value of -1, like so:



>>> table.sort(key=lambda a, b: cmp(a[’U’], b[’U’]))



>>> table




 
 [[’A’, ‘B’, ‘C’], [’B’, ‘A’, ‘C’], [’A’, ‘B’, ‘C’]]



You can also do this as a one-liner by sorting the table twice and then appending the sorted table to itself. This is more complex, but we can use the sort() function. Here’s a one-liner:



>>> table.sort(key=lambda a, b: cmp(a[’U’], b[’U’]))



>>> table = sorted(table, key=lambda a, b: cmp(a[’U’], b[’U’]))



>>> table




 
 [[’A’, ‘B’, ‘C’], [’B’, ‘A’, ‘C’], [’A’, ‘B’, ‘C’]]



In [21]: table = sorted(table, key=lambda a, b: cmp(a[’U’], b[’U’]))



The two-line version is also useful if we want to sort several tables, since we can use a list of tables to sort a single table. The two-line version would look like this:



tables = [table1, table2, …] sorted_tables = [sorted(t, key=lambda a, b: cmp(a[’U’], b[’U’])) for t in tables]




 
 You could also use itertools:



from itertools import group by sorted(groupby(data, lambda x: x[’U’]), key=lambda x: x[1])




 
 The output:



[(’A’, ‘B’, ‘C’), (’B’, ‘A’, ‘C’), (’A’, ‘B’, ‘C’)




 
 Here is an alternative one-liner that I’ve found works nicely:



t = [’A’,’B’,’C’,’D’,’E’,’F’,’G’,’H’,’I’,’J’,’K’,’L’,’M’,’








LEFT and RIGHT




This can be done by using the IF function with the INDIRECT function to calculate with cells which are on other sheets.



For instance if your cell is in A1 then you can try this:



=IF(INDIRECT(” & Sheet2.Name & ’!B” & ROWS(1).VALUE & ”)=”Yes”, “TRUE”, “FALSE”)







Also if you want to show TRUE as text the easiest is to use the TEXT function.



It is actually much simpler than that.








 
 Try this:



=SUMPRODUCT(1:1>OFFSET(Sheet2!$A$2,0,ROWS(A:A)-ROW(A1),0))



If you have a header row, you may need to put it somewhere else like this:



=SUMPRODUCT(1:1>OFFSET(Sheet2!$A$2,0,ROWS(1:1)-1,0))








 
 You should get the same result with the following formulas:



=SUMPRODUCT(1:1>OFFSET(Sheet2!$B$2,0,ROWS(1:1)-ROW(A1),0))



=SUMPRODUCT(1:1>OFFSET(Sheet2!$A$2,0,ROWS(1:1)-1,0))








MATCH




“This is a super basic question, I want to know the right syntax in Microsoft Excel to use a formula to find the index of the last occurance of a match.



For example if I want to find the index of the last 1 in 123456789 or last two 1’s in 123456789.



I’m aware of the MATCH function but this will only work with whole numbers.”







You need to count the number of zeroes before the last non-zero.



For instance:



=MATCH(SUMPRODUCT(--(C1:C10=”1”))/10,--(C1:C10=0),0)-ROW() will return 0, 4, 7, respectively.



Note that there’s a faster way.



SUMPRODUCT(--(C1:C10=”1”))/10 --> 2



SUMPRODUCT(--(C1:C10=0)) --> 10



ROW() -2 --> 4








 
 You could use:



=MATCH(0,1/(INDEX(--C1:C10,MATCH(0,--C1:C10,0))<>0),0)




 
 In your cell you would enter this formula like this:



=MATCH(0,1/(INDEX(--C1:C10,MATCH(0,--C1:C10,0))<>0),0)



Which looks up the zero in Column C, counts how many values it finds after it (only counting the zero’s) and gives you the first number that does not have a match after it.



As a short explanation:



The part with C1:C10 means “column C to column 10 of range C1:C10”. It’s only counting the zeros and then looking up the value in column C where that many zeros should exist.



The INDEX(--C1:C10,MATCH(0,--C1:C10,0)) part is the part that determines what column you will look at after you have counted the number of zeros. The --C1:C10 tells it to start from column C1 to the end of the range. The --C1:C10 part tells it to start at the 0 position and then match on the position of zero. The MATCH(0,--C1:C10,0) part tells it to only look at the column where the first zero is (zero position 0).



The 0 in the end is a bit confusing and you probably don’t need that (unless you want to use this to find out if there are any zeros after that point). It tells it to use column 0, since we just told it to start at position 0 in the --C1:C10 part.



All together, it means “start at Column C1, count up to where we find a match on position zero in C1:C10, if there is a match, stop. You don’t need that final 0 part so you can just delete that.”



EDIT: Since you can’t remove numbers from a cell you can use this formula:



=MATCH(0,1/(INDEX(--C1:C10








INDEX




INDEX in Microsoft excel works like this:



The number of columns to the right of the =VALUE(INDEX(data,1,COLUMN(data),1,1) is equal to the number of rows. This is probably not a problem as long as all formulas are in the same workbook and all sheets are named “table” (i know i can use “ActiveSheet.Name” etc. but i want to know how to do this dynamiclly).



Question:



“What is the formula that gets the number of rows in an Excel sheet which the value in the A column is “something”?



“How can i set this number in the number of columns to the right of the =VALUE(INDEX()) to be equal to the number of rows in the sheet. (so basically i want to apply a function on a function which gets the number of rows in a sheet.”?




 
 You are asking for a formula.



=LEN(A1)-COLUMN(A1)



This formula needs to be part of a cell, not in the formula bar.














CONCLUSION




Microsoft excel 2021, the new version is the continuation of v6, with new version added new features. This software is used to view files, manipulate data and work with numbers, dates, and texts. Microsoft excel 2021 can be installed on your system without any cost. This software has a lot of features such as easy-to-use functions. Microsoft excel 6 has many versions which were released in the year 2004 to 2019. V6 exam is the latest version and this software is compatible with Windows 10, 8.1, Windows 8 and Windows 7. V6 is the easiest version to work with. It is used to manage and organize work and personal documents, which helps to reduce the use of unnecessary paper documents.



This version is available in two forms- personal and enterprise. You can purchase the software online as well as download, it is available in many languages and for several users. You can also use this software as a desktop application as well. If you are new to Microsoft excel, you have to perform certain actions. To start using the software, you need to have a trial version. Once you use the trial version, you can use the software and try the functions which are offered by it. You can also upgrade to the latest version as you have to with all the latest software available online.



If you have a subscription to Microsoft Office, you can use the latest version of the software. You can also use this software to learn more about the features it provides to the user. If you don’t like the earlier version, you can get the latest version and use it. This version is easy to download as you need to visit the site to download it. There are thousands of users who can use this software to get the latest features and updates. You can even learn to use the features and learn more about this software.
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